<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" > 
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta name="distribution" content="global" />
	<meta name="robots" content="follow, all" />
	<meta name="language" content="en, sv" />
	<meta name="viewport" content="width=device-width" />
		<link rel="Shortcut Icon" href="https://www.talonmarks.com/wp-content/uploads/2017/09/favicon-1.png" type="image/x-icon" />
	<link rel="alternate" type="application/rss+xml" title="Talon Marks RSS 2.0" href="https://www.talonmarks.com/feed/" />
	<link rel="alternate" type="text/xml" title="Talon Marks RSS .92" href="https://www.talonmarks.com/feed/rss/" />
	<link rel="alternate" type="application/atom+xml" title="Talon Marks Atom 0.3" href="https://www.talonmarks.com/feed/atom/" />
	<title>Off The Field: Worst NFL coach Urban Meyer | Talon Marks</title>

		<!-- All in One SEO 4.1.5.3 -->
		<meta name="description" content="This is Urban Meyer’s first year ever coaching in the NFL and it is safe to say that he will go down as one of the worst NFL coaches ever. The firing comes right after former Jaguars’ kicker Josh Lambo accused Meyer of kicking him before a game as well as verbally attacking him. Meyer..." />
		<meta name="robots" content="max-image-preview:large" />
		<meta name="keywords" content="jaguars,nfl,sports opinion,urban meyer" />
		<link rel="canonical" href="https://www.talonmarks.com/sports/2021/12/19/off-the-field-worst-nfl-coach-urban-meyer/" />
		<meta property="og:locale" content="en_US" />
		<meta property="og:site_name" content="Talon Marks | Cerritos College • Norwalk, Calif." />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Off The Field: Worst NFL coach Urban Meyer | Talon Marks" />
		<meta property="og:description" content="This is Urban Meyer’s first year ever coaching in the NFL and it is safe to say that he will go down as one of the worst NFL coaches ever. The firing comes right after former Jaguars’ kicker Josh Lambo accused Meyer of kicking him before a game as well as verbally attacking him. Meyer..." />
		<meta property="og:url" content="https://www.talonmarks.com/sports/2021/12/19/off-the-field-worst-nfl-coach-urban-meyer/" />
		<meta property="article:published_time" content="2021-12-19T19:58:56+00:00" />
		<meta property="article:modified_time" content="2021-12-19T19:58:56+00:00" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:domain" content="www.talonmarks.com" />
		<meta name="twitter:title" content="Off The Field: Worst NFL coach Urban Meyer | Talon Marks" />
		<meta name="twitter:description" content="This is Urban Meyer’s first year ever coaching in the NFL and it is safe to say that he will go down as one of the worst NFL coaches ever. The firing comes right after former Jaguars’ kicker Josh Lambo accused Meyer of kicking him before a game as well as verbally attacking him. Meyer..." />
		<meta name="google" content="nositelinkssearchbox" />
		<script type="application/ld+json" class="aioseo-schema">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</script>
		<!-- All in One SEO -->

<link rel="alternate" type="application/rss+xml" title="Talon Marks &raquo; Off The Field: Worst NFL coach Urban Meyer Comments Feed" href="https://www.talonmarks.com/sports/2021/12/19/off-the-field-worst-nfl-coach-urban-meyer/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.talonmarks.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
			
	<link rel='stylesheet' id='dashicons-css'  href='https://www.talonmarks.com/wp-includes/css/dashicons.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='https://www.talonmarks.com/wp-includes/js/thickbox/thickbox.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://www.talonmarks.com/wp-content/plugins/instagram-feed/css/sbi-styles.min.css?ver=2.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='ytwd_frontend_main-css-css'  href='https://www.talonmarks.com/wp-content/plugins/wd-youtube/css/frontend_main.css?ver=1.0.20' type='text/css' media='all' />
<link rel='stylesheet' id='ytwd_bootstrap-css-css'  href='https://www.talonmarks.com/wp-content/plugins/wd-youtube/css/bootstrap.css?ver=1.0.20' type='text/css' media='all' />
<link rel='stylesheet' id='ytwd_font-css-css'  href='https://www.talonmarks.com/wp-content/plugins/wd-youtube/css/font-awesome/font-awesome.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='elusive-css'  href='https://www.talonmarks.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.talonmarks.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link rel='stylesheet' id='foundation-icons-css'  href='https://www.talonmarks.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/foundation-icons.min.css?ver=3.0' type='text/css' media='all' />
<link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.talonmarks.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.talonmarks.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='my-calendar-reset-css'  href='https://www.talonmarks.com/wp-content/plugins/my-calendar/css/reset.css?ver=3.2.19' type='text/css' media='all' />
<link rel='stylesheet' id='my-calendar-style-css'  href='https://www.talonmarks.com/wp-content/plugins/my-calendar/styles/my-calendar.css?ver=3.2.19' type='text/css' media='all' />
<link rel='stylesheet' id='sno-infographics-widget-style-css'  href='https://www.talonmarks.com/wp-content/plugins/sno-infographics/assets/style/sno-infographics-widget-style.css?ver=0.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='sno-pdf-flipbook-plugin-style-css'  href='https://www.talonmarks.com/wp-content/plugins/sno-pdf-flipbook/assets/style/docs.css?ver=1.0.6' type='text/css' media='all' />
<link rel='stylesheet' id='sno-pdf-flipbook-jquery-ui-style-css'  href='https://www.talonmarks.com/wp-content/plugins/sno-pdf-flipbook/assets/style/jquery.ui.css?ver=1.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='sno-polls-widget-style-css'  href='https://www.talonmarks.com/wp-content/plugins/sno-polls/assets/style/sno-polls-widget-style.css?ver=0.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='sno-student-news-source-popup-style-css'  href='https://www.talonmarks.com/wp-content/plugins/sno-student-news-source/assets/style/sno-student-news-source-popup.css?ver=all' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://www.talonmarks.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background: #004282;
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='sno-comments-css-css'  href='https://www.talonmarks.com/wp-content/themes/snoflex/comments/comments.css?ver=20211015' type='text/css' media='all' />
<link rel='stylesheet' id='googleFonts-css'  href='https://fonts.googleapis.com/css?family=Oswald%3A400%2C700%7CLato%3A400%2C700&#038;display=swap&#038;ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='flex-parallax-css'  href='https://www.talonmarks.com/wp-content/themes/snoflex/parallax/css/main.css?ver=20191203' type='text/css' media='all' />
<link rel='stylesheet' id='flex-flexslider-css'  href='https://www.talonmarks.com/wp-content/themes/snoflex/tools/flexslider/flexslider.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-superfish-css'  href='https://www.talonmarks.com/wp-content/themes/snoflex/tools/superfish/css/superfish.css?ver=20210512' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-css'  href='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/remodal.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-remodal-default-css'  href='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/remodal-default-theme.css?ver=20180208' type='text/css' media='all' />
<link rel='stylesheet' id='flex-stylesheet-css'  href='https://www.talonmarks.com/wp-content/themes/snoflex/style.css?ver=20211209' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-official-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/all.css' type='text/css' media='all' integrity="sha384-vSIIfh2YWi9wW0r9iZe7RJPrKwp6bG+s9QZMoITbCckVJqGCCRhc+ccxNcdpHuYu" crossorigin="anonymous" />
<link rel='stylesheet' id='font-awesome-official-v4shim-css'  href='https://use.fontawesome.com/releases/v5.15.2/css/v4-shims.css' type='text/css' media='all' integrity="sha384-1CjXmylX8++C7CVZORGA9EwcbYDfZV2D4Kl1pTm3hp2I/usHDafIrgBJNuRTDQ4f" crossorigin="anonymous" />
<style id='font-awesome-official-v4shim-inline-css' type='text/css'>
@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-brands-400.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-solid-900.svg#fontawesome") format("svg");
}

@font-face {
font-family: "FontAwesome";
font-display: block;
src: url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.eot?#iefix") format("embedded-opentype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff2") format("woff2"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.woff") format("woff"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.ttf") format("truetype"),
		url("https://use.fontawesome.com/releases/v5.15.2/webfonts/fa-regular-400.svg#fontawesome") format("svg");
unicode-range: U+F004-F005,U+F007,U+F017,U+F022,U+F024,U+F02E,U+F03E,U+F044,U+F057-F059,U+F06E,U+F070,U+F075,U+F07B-F07C,U+F080,U+F086,U+F089,U+F094,U+F09D,U+F0A0,U+F0A4-F0A7,U+F0C5,U+F0C7-F0C8,U+F0E0,U+F0EB,U+F0F3,U+F0F8,U+F0FE,U+F111,U+F118-F11A,U+F11C,U+F133,U+F144,U+F146,U+F14A,U+F14D-F14E,U+F150-F152,U+F15B-F15C,U+F164-F165,U+F185-F186,U+F191-F192,U+F1AD,U+F1C1-F1C9,U+F1CD,U+F1D8,U+F1E3,U+F1EA,U+F1F6,U+F1F9,U+F20A,U+F247-F249,U+F24D,U+F254-F25B,U+F25D,U+F267,U+F271-F274,U+F279,U+F28B,U+F28D,U+F2B5-F2B6,U+F2B9,U+F2BB,U+F2BD,U+F2C1-F2C2,U+F2D0,U+F2D2,U+F2DC,U+F2ED,U+F328,U+F358-F35B,U+F3A5,U+F3D1,U+F410,U+F4AD;
}
</style>
<link rel='stylesheet' id='snoadrotate-default-css-css'  href='https://www.talonmarks.com/wp-content/plugins/sno-ad-rotate/css/widget-default.css?ver=1.0' type='text/css' media='screen' />
<link rel='stylesheet' id='wp-paginate-css'  href='https://www.talonmarks.com/wp-content/plugins/wp-paginate/css/wp-paginate.css?ver=2.1.8' type='text/css' media='screen' />
<script type='text/javascript' src='https://www.talonmarks.com/wp-includes/js/swfobject.js?ver=2.2-20120417' id='swfobject-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/wd-youtube/js/linkify.js?ver=5.8.2' id='ytwd_linkify-js-js'></script>
<script type='text/javascript' src='https://apis.google.com/js/platform.js?ver=5.8.2' id='ytwd_platform-js-js'></script>
<script type='text/javascript' id='sno-comments-js-js-extra'>
/* <![CDATA[ */
var comment_ajax_object = {"ajaxurl":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php","nonce":"3d7497691c","jason":"wallestad"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/comments/comments.js?ver=20211013' id='sno-comments-js-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/tools/flexslider/jquery.flexslider.js?ver=5.8.2' id='flex-flexslider-script-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/jquery-visible.js?ver=5.8.2' id='flex-jquery-visible-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/tools/superfish/js/hoverintent.js?ver=20210512' id='flex-hoverintent-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/tools/superfish/js/superfish.js?ver=20210513' id='flex-superfish-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/tools/superfish/js/supersubs.js?ver=20210513' id='flex-supersubs-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/jquery-scrolltofixed-min.js?ver=5.8.2' id='flex-scrollfix-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/remodal.min.js?ver=5.8.2' id='flex-remodal-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/jquery.cycle.all.min.js?ver=5.8.2' id='flex-cycle-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/jcarousellite_1.0.1c4.js?ver=5.8.2' id='flex-bnticker-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/menus-init.js?ver=20210513' id='flex-menus-js'></script>
<script type='text/javascript' id='flex-theme-js-js-extra'>
/* <![CDATA[ */
var frontend_ajax_object = {"ajaxurl":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/javascript/sno-theme.js?ver=20211002' id='flex-theme-js-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/themes/snoflex/parallax/js/skrollr.js?ver=5.8.2' id='flex-parallax-js'></script>

<script type="text/javascript" charset="utf-8">
	(function(){
		try {
			// Disabling SWFObject's Autohide feature
			if (typeof swfobject.switchOffAutoHideShow === "function") {
				swfobject.switchOffAutoHideShow();
			}
		} catch(e) {}
	})();
</script>
<link rel="https://api.w.org/" href="https://www.talonmarks.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.talonmarks.com/wp-json/wp/v2/posts/10055859" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.talonmarks.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.talonmarks.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://www.talonmarks.com/?p=10055859' />
<link rel="alternate" type="application/json+oembed" href="https://www.talonmarks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.talonmarks.com%2Fsports%2F2021%2F12%2F19%2Foff-the-field-worst-nfl-coach-urban-meyer%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.talonmarks.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.talonmarks.com%2Fsports%2F2021%2F12%2F19%2Foff-the-field-worst-nfl-coach-urban-meyer%2F&#038;format=xml" />

<style type="text/css">
<!--
/* Styles by My Calendar - Joseph C Dolson https://www.joedolson.com/ */

.mc-main .mc_general .event-title, .mc-main .mc_general .event-title a { background: #ffffff; color: #000000; }
.mc-main .mc_general .event-title a:hover, .mc-main .mc_general .event-title a:focus { background: #ffffff;}
.mc-main .mc_concert .event-title, .mc-main .mc_concert .event-title a { background: #00FF00; color: #000000; }
.mc-main .mc_concert .event-title a:hover, .mc-main .mc_concert .event-title a:focus { background: #33ff33;}
.mc-main .mc_meeting .event-title, .mc-main .mc_meeting .event-title a { background: #C0C0C0; color: #000000; }
.mc-main .mc_meeting .event-title a:hover, .mc-main .mc_meeting .event-title a:focus { background: #f3f3f3;}
.mc-main .mc_club-activity .event-title, .mc-main .mc_club-activity .event-title a { background: #CC3366; color: #ffffff; }
.mc-main .mc_club-activity .event-title a:hover, .mc-main .mc_club-activity .event-title a:focus { background: #990033;}
.mc-main .mc_theatre .event-title, .mc-main .mc_theatre .event-title a { background: #FF00FF; color: #ffffff; }
.mc-main .mc_theatre .event-title a:hover, .mc-main .mc_theatre .event-title a:focus { background: #cc00cc;}
.mc-main .mc_ascc-activity .event-title, .mc-main .mc_ascc-activity .event-title a { background: #FFFF00; color: #000000; }
.mc-main .mc_ascc-activity .event-title a:hover, .mc-main .mc_ascc-activity .event-title a:focus { background: #ffff33;}
.mc-main .mc_campus-wide .event-title, .mc-main .mc_campus-wide .event-title a { background: #9999ff; color: #000000; }
.mc-main .mc_campus-wide .event-title a:hover, .mc-main .mc_campus-wide .event-title a:focus { background: #ccccff;}
.mc-main .mc_print-edition .event-title, .mc-main .mc_print-edition .event-title a { background: #00FFFF; color: #000000; }
.mc-main .mc_print-edition .event-title a:hover, .mc-main .mc_print-edition .event-title a:focus { background: #33ffff;}
.mc-main .mc_fundraiser .event-title, .mc-main .mc_fundraiser .event-title a { background: #fca4ef; color: #000000; }
.mc-main .mc_fundraiser .event-title a:hover, .mc-main .mc_fundraiser .event-title a:focus { background: #ffd7ff;}
.mc-main .mc_workshop .event-title, .mc-main .mc_workshop .event-title a { background: #c8ace2; color: #000000; }
.mc-main .mc_workshop .event-title a:hover, .mc-main .mc_workshop .event-title a:focus { background: #fbdfff;}
.mc-main .mc_sporting-events .event-title, .mc-main .mc_sporting-events .event-title a { background: #6a92ba; color: #000000; }
.mc-main .mc_sporting-events .event-title a:hover, .mc-main .mc_sporting-events .event-title a:focus { background: #9dc5ed;}
.mc-main .mc_art-gallery .event-title, .mc-main .mc_art-gallery .event-title a { background: #ddaf6a; color: #000000; }
.mc-main .mc_art-gallery .event-title a:hover, .mc-main .mc_art-gallery .event-title a:focus { background: #ffe29d;}
.mc-main {--primary-dark: #313233; --primary-light: #fff; --secondary-light: #fff; --secondary-dark: #000; --highlight-dark: #666; --highlight-light: #efefef; --category-mc_general: #ffffff; --category-mc_concert: #00FF00; --category-mc_meeting: #C0C0C0; --category-mc_club-activity: #CC3366; --category-mc_theatre: #FF00FF; --category-mc_ascc-activity: #FFFF00; --category-mc_campus-wide: #9999ff; --category-mc_print-edition: #00FFFF; --category-mc_fundraiser: #fca4ef; --category-mc_workshop: #c8ace2; --category-mc_sporting-events: #6a92ba; --category-mc_art-gallery: #ddaf6a; }
-->
</style>

<!-- Start of Open Graph Meta Tags -->

<meta property="og:title" content="Off The Field: Worst NFL coach Urban Meyer" />
<meta property="og:type" content="article" />
<meta name="author" content="Silas Bravo" />
<meta property="og:url" content="https://www.talonmarks.com/sports/2021/12/19/off-the-field-worst-nfl-coach-urban-meyer/" />
<meta property="og:image" content="https://www.talonmarks.com/wp-content/uploads/2019/10/header_standard-1-200px-large.png" />
	<meta property="og:image:width" content="900" />
	<meta property="og:image:height" content="161" />
	<meta property="og:site_name" content="Talon Marks" />
	<meta property="og:description" content="The Jacksonville Jaguars finally let go of legendary college football coach Urban Meyer after only couple games." />
	<meta name="description" content="The Jacksonville Jaguars finally let go of legendary college football coach Urban Meyer after only couple games." />
	<meta property="article:section" content="Football" />
	<meta property="article:tag" content="Jaguars,nfl,Sports opinion,Urban Meyer" />
<!-- End of Open Graph Meta Tags -->

		<style type="text/css" media="screen">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</style></head>
<body data-rsssl=1 class="sno-animate-active">

 

	<div id="wrap" class="bodywrap">
		
											<div class="sno-header-wrap sno-header-wrap-desktop">
																																																																																																															<div class="sno-designer-area-row sno-designer-area-row-desktop-1" style="background: #ffffff; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-desktop-1" style="width: 100%; height: 175px;">
																			<style>
	.sno-hac-inner-desktop-1 {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-desktop-1 h1 {
		text-align: center;
		color: #000000;
		padding: 0 15px;
		font-size: 36px;
		font-family: Lato;
		font-weight: 400;
		margin-bottom: 0;
	}
	.sno-hac-inner-desktop-1 .sno-hac-textwrap {
		position: absolute;
		top: 50%;
		transform: translateY(-50%);
		left: 0;
		right: 0;
	}
	.sno-hac-inner-desktop-1 h1 {
		margin-top: 0;
	}
	.sno-hac-inner-desktop-1 .sno-hac-headerimage {
		object-fit: contain;
	}
</style>
<a href="https://www.talonmarks.com/">
	<div class="sno-hac-inner sno-hac-inner-desktop-1">
				<img src="https://www.talonmarks.com/wp-content/uploads/2021/08/TM-Logo-BLUE.jpeg" class="sno-hac-headerimage" alt="Cerritos College • Norwalk, Calif." />
		<div class="sno-hidden-title">
			<h1>Talon Marks</h1>
		</div>
		</div>
</a>																	</div>
																					</div>
					</div>
					<div class="clear"></div>
																																																																					<div class="sno-designer-area-row sno-designer-area-row-desktop-2" style="background: transparent; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-desktop-2" style="width: 33%; height: 50px;">
																			<style>
	.sno-hac-inner-desktop-2 {
		background: transparent;
		overflow: hidden;
		padding-left: 0px;
		padding-right: 0px;
		width: calc(100% - (2 * 0px));
	}
	.sno-hac-inner-desktop-2 .sno-icon {
		height: 30px;
		width: 30px;
		line-height: 30px;
		font-size: calc(30px * 2 / 3);
		border-radius: 5px;
		margin-right: 5px;
		
	}
	.sno-hac-inner-desktop-2 .sno-hac-iconwrap {
		text-align: left;
		margin-left: 5px;
	}
	.sno-hac-inner-desktop-2 .sno-hac-iconwrap a:nth-of-type(9) .sno-icon {
		margin-right: 0;	
	}
	.sno-hac-inner-desktop-2 .sno-hac-iconwrap a:nth-of-type(n + 10) {
		display: none;	
	}


	.sno-hac-inner-desktop-2 .sno-icon {
		margin-top: 10px;
		margin-bottom: 10px;
	}
	.icon-monochromatic-desktop-2 .sno-icon {
		background: #990000;
		color: #fff;
	} 
	.icon-monochromatic-inverse-hover-desktop-2 .sno-icon:hover {
		color: #990000;
		background: #fff;
	}
	.icon-monochromatic-inverse-desktop-2 .sno-icon {
		color: #990000;
		background: #fff;
	}
	.icon-monochromatic-hover-desktop-2 .sno-icon:hover {
		background: #990000;
		color: #fff;
	}
	.icon-monochromatic-desktop-2 .sno-icon i, .icon-monochromatic-inverse-desktop-2 .sno-icon i {
		-webkit-text-stroke-width: 0px !important;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-2 icon-standard-desktop-2 icon-hover-standard">
	<div class="sno-hac-iconwrap">
			<a target="_blank" href="https://facebook.com/talonmarks">
		<div class="sno-icon social-border sno-facebook">
    		<i class="fa fa-facebook-f"></i>
    		<span class="icon-hidden-text">Facebook</span>
    	</div>
	</a>

	<a target="_blank" href="https://twitter.com/talonmarks">
		<div class="sno-icon social-border sno-twitter">
    		<i class="fa fa-twitter"></i>
    		<span class="icon-hidden-text">Twitter</span>
    	</div>
	</a>

	<a target="_blank" href="https://www.instagram.com/talonmarks">
		<div class="sno-icon social-border sno-instagram">
    		<i class="fa fa-instagram"></i>
    		<span class="icon-hidden-text">Instagram</span>
    	</div>
	</a>









	<a target="_blank" href="https://www.snapchat.com/add/talonmarks">
		<div class="sno-icon social-border sno-snapchat">
    		<i class="fa fa-snapchat-ghost"></i>
    		<span class="icon-hidden-text">Snapchat</span>
    	</div>
	</a>

	<a target="_blank" href="https://www.youtube.com/user/talonmarksmedia">
		<div class="sno-icon social-border sno-youtube">
    		<i class="fa fa-youtube-play"></i>
    		<span class="icon-hidden-text">YouTube</span>
    	</div>
	</a>


	

	<a target="_blank" href="https://www.talonmarks.com/subscribe/">
		<div class="sno-icon social-border sno-email">
    		<i class="fa fa-envelope"></i>
    		<span class="icon-hidden-text">Email Signup</span>
    	</div>
	</a>

									
	<a target="_blank" href="https://www.talonmarks.com/feed/rss/">
    	<div class="sno-icon social-border sno-rss">
        	<i class="fa fa-rss"></i>
        	<span class="icon-hidden-text">RSS Feed</span>
        </div>
	</a>
	</div>
</div>


																	</div>
																																																							<div class="sno-designer-area-container sno-hac-desktop-3" style="width: 33%; height: 50px;">
																			<style>
	.sno-hac-inner-desktop-3 {
		background: transparent;
		border: 0px solid #eeeeee;
		margin: 0px;
		color: #000000;
		text-align: center;
		font-family: Lato;
		font-weight: normal;
		font-style: normal;
		font-size: 18px;
		line-height: 25.2px;
	}
	.sno-hac-inner-desktop-3 {
		height: calc(100% - (0px * 2) - (0px * 2));
	}
	.sno-hac-inner-desktop-3 {
		width: calc(100% - (0px * 2) - (0px * 2));
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-3">
	<div class="sno-hac-date sno-hac-textwrap sno-hac-center-v">
		<script src="https://www.talonmarks.com/wp-content/themes/snoflex/javascript/date.js?ver=1" type="text/javascript"></script>
	</div>
</div>
																	</div>
																																																							<div class="sno-designer-area-container sno-hac-desktop-4" style="width: 34%; height: 50px;">
																			<style>
	.sno-hac-inner-desktop-4 {
		background: transparent;
		border: 0px solid #eeeeee;
		margin: 0px;
		font-family: Lato;
	}
	.sno-hac-inner-desktop-4 {
		height: calc(100% - (0px * 2) - (0px * 2));
	}
	.sno-hac-inner-desktop-4 {
		width: calc(100% - (0px * 2) - (0px * 2));
	}
	.sno-hac-inner-desktop-4 .sno-search-center-v {
		left: 10%;
		right: 10%;
	}
	.sno-hac-inner-desktop-4 input.hac-search {
		background: #ffffff;
		color: #aaaaaa;
		border-color: #aaaaaa;
		border-width: 1px;
		border-radius: 0px;
	}
	.sno-hac-inner-desktop-4 input.hac-search::placeholder,
	.sno-hac-inner-desktop-4 .sno-hac-submit-search-button {
		color: #aaaaaa;
	}
	.sno-hac-inner-desktop-4 input.hac-search:focus {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-desktop-4 input.hac-search:focus::placeholder,
	.sno-hac-inner-desktop-4 input.hac-search:focus + .sno-hac-submit-search-button {
		color: #000000;
	}	
	.sno-hac-inner-desktop-4 .sno-hac-search-inner-wrap {
		width: 100%;
		max-width: 100%;
	}
	.sno-hac-inner-desktop-4 .sno-hac-submit-search-button {
		right: 8px;
		padding-right: 9px;
		font-size: 12px;
		line-height: 12px;
	}
	.sno-hac-inner-desktop-4 input.hac-search {
		font-size: 16px;
		line-height: 32px;
		padding: 8px 8px;
		padding-right: 40px;
		border: 1px solid #aaaaaa;
		max-width: calc(100% - (8px * 2) - (1px * 2) - 40px);
		width: calc(100% - (8px * 2) - (1px * 2) - 40px);
	}
	
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-4">
	<div class="sno-hac-textwrap sno-search-center-v">
		<form method="get" action="https://www.talonmarks.com/">
			<div class="sno-hac-search-inner-wrap">
				<label for="s-desktop-4" class="assistive-text">Search this site</label>
				<input type="text" class="field hac-search" name="s" id="s-desktop-4" placeholder="Enter Search Term" />
				<button type="submit" class="sno-hac-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
		</form>
	</div>
</div>																	</div>
																					</div>
					</div>
					<div class="clear"></div>
																																																																					<div class="sno-designer-area-row sno-designer-area-row-desktop-3" style="background: #ffffff; border-bottom: 10px solid #ffffff; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-desktop-5" style="width: 100%; height: 73px;">
																			<style>
	.sno-hac-inner-desktop-5 {
		background: #002e66;
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap li.menu-item-has-children:not(.sub-menu-teasers) ul { 
		max-width: 12em; 
	}
	.sno-hac-inner-desktop-5 ul.sno-hac-menu-more ul.sub-menu { 
		right: 12em; 
	}
 
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap {
		background: #002e66;
		color: #ffffff;
		line-height: 73px;
		height: 73px;
		font-weight: normal;
		font-family: Oswald;
		margin-left: 0px;
		margin-right: 0px;
		width: calc(100% - (2 * 0px));
		text-transform: capitalize; 
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap li {
		background: #002e66;
		color: #ffffff;
		line-height: 73px;
		font-size: 16px;
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap > div > ul > li, .sno-hac-inner-desktop-5 li.menu-more-item-top {
		border-right: 0px solid #ffffff;
		border-top: 0px solid #ffffff;
		border-bottom: 0px solid #ffffff;
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap > div > ul > li:first-of-type {
		border-left: 0px solid #ffffff;
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap li a:not(.menuheadline) {
		color: #ffffff;
		line-height: 73px;
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap a:not(.menuheadline):hover,
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap a:not(.menuheadline):focus {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-desktop-5 .sf-arrows > li > .sf-with-ul:after,
	.sno-hac-inner-desktop-5 .sf-arrows > li > .sf-with-ul:after,
	.sno-hac-inner-desktop-5 .sf-arrows > .sf-with-ul:after {
		border-top-color: #ffffff;
	}
	.sno-hac-inner-desktop-5 .sf-arrows > li > .sf-with-ul:focus:after,
	.sno-hac-inner-desktop-5 .sf-arrows > li:hover > .sf-with-ul:after,
	.sno-hac-inner-desktop-5 .sf-arrows > .sfHover > .sf-with-ul:after {
		border-top-color: #000000; 
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap li li {
		line-height: 50px;
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap li li a:not(.menuheadline) {
		line-height: 50px;
	}
	.sno-hac-inner-desktop-5 ul.sf-menu {
		float: left;
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap {
		margin-top: 0px; 
	}
	.sno-hac-inner-desktop-5 .sno-hac-menuwrap li a:not(.menuheadline):hover::before {
		border-left: 5px solid #002e66;
		top: 5px;
		left: 5px;
		bottom: 5px;
		width: 5px;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-5">
	<nav aria-label="Navigation Menu">
		<div class="sno-hac-menuwrap">
			<div class="menu-top-menu-container"><ul id="menu-top-menu" class="sf-menu"><li id="menu-item-10017172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10017172"><a href="https://www.talonmarks.com/category/news/">News</a></li>
<li id="menu-item-10049343" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10049343"><a href="https://www.talonmarks.com/category/covid-19/">COVID-19</a></li>
<li id="menu-item-10045018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10045018"><a href="https://www.talonmarks.com/category/community/">Community</a></li>
<li id="menu-item-10029303" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10029303"><a href="https://www.talonmarks.com/category/arts-entertainment/">Arts &amp; Entertainment</a></li>
<li id="menu-item-10017174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10017174"><a href="https://www.talonmarks.com/category/opinion/">Opinion</a></li>
<li id="menu-item-10017173" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10017173"><a href="https://www.talonmarks.com/category/sports/">Sports</a></li>
<li id="menu-item-10045446" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10045446"><a href="https://www.talonmarks.com/category/multimedia/">Multimedia</a></li>
<li id="menu-item-10043006" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10043006"><a href="https://www.talonmarks.com/classifieds/">Classifieds</a></li>
<li id="menu-item-10050008" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10050008"><a href="https://www.talonmarks.com/subscribe/">Subscribe</a></li>
<li id="menu-item-171" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-171"><a href="https://www.talonmarks.com/about/">About TM</a>
<ul class="sub-menu">
	<li id="menu-item-172" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-172"><a href="https://www.talonmarks.com/staff/">Staff</a></li>
	<li id="menu-item-10048219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10048219"><a href="https://www.talonmarks.com/got-a-news-tip/">Got a News Tip?</a></li>
	<li id="menu-item-364" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-364"><a href="https://www.talonmarks.com/submit-a-letter/">Submit a Letter</a></li>
	<li id="menu-item-1003238" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003238"><a href="https://www.talonmarks.com/about/media-kit-advertising/">Media Kit</a></li>
	<li id="menu-item-10022555" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10022555"><a href="https://www.talonmarks.com/category/print/">Print</a></li>
	<li id="menu-item-10038182" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10038182"><a href="https://www.talonmarks.com/archives/">Archives</a></li>
</ul>
</li>
</ul></div>			<ul class='sno-menu-more sf-arrows' style='display:none'>
				<li class="menu-more-item-top">
					<a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"></span></a>
					<ul class="sno-hac-menu-more"></ul>
				</li>
			</ul>
		</div>
	</nav>
</div>


																	</div>
																					</div>
					</div>
					<div class="clear"></div>
																																																																					<div class="sno-designer-area-row sno-designer-area-row-desktop-4" style="background: transparent; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-desktop-6" style="width: 100%; height: 30px;">
																			<style>
	.sno-hac-inner-desktop-6 {
		background: transparent;
	}
	.sno-hac-inner-desktop-6 .marquee-sibling {
		background: #990000;
		color: #ffffff;
		padding: 0 30px;
		font-family: Oswald;
		font-weight: normal;
		font-size: 16px;
		height: 30px;
		line-height: 30px;
	}
	.sno-hac-inner-desktop-6 .simple-marquee-container {
		background: #ffffff;
		font-size: 16px;
		height: 30px;
		line-height: 30px;
		
	}
	.sno-hac-inner-desktop-6 .simple-marquee-container .marquee-content-items {
		height: 30px;
		line-height: 30px;
	}
	.sno-hac-inner-desktop-6 .marquee-content-items li {
		color: #000000;
		height: 30px;
		line-height: 30px;
		padding-right: 40px;
		font-family: Oswald;
		font-weight: normal;
	}
	.sno-hac-inner-desktop-6 .marquee-angle {
		border-top: 15px solid transparent;
		border-bottom: 15px solid transparent;
		border-left: 7.5px solid #990000;
		margin-left: 30px;
	}
	.sno-hac-inner-desktop-6 .marquee-inverse-angle {
		border-top: 15px solid #990000;
		border-bottom: 15px solid #990000;
		border-left: 7.5px solid #ffffff;
		margin-left: 0;
	}
	.sno-hac-inner-desktop-6 .date-background {
		background: #444444;
		color: #ffffff;
	}
	.sno-hac-inner-desktop-6 li a {
		color: #000000 !important;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-6">
	<div class="sno-hac-textwrap sno-marquee-center-v">
		<div class="simple-marquee-container" data-activate="true">
						<div class="marquee" data-speed=".05">
				<ul class="marquee-content-items">
		
												
				</ul>
			</div>
		</div>


	</div>
</div>
																	</div>
																					</div>
					</div>
					<div class="clear"></div>
										</div>
					<div class="sno-header-wrap sno-header-wrap-tablet">
																																																																																																															<div class="sno-designer-area-row sno-designer-area-row-tablet-1" style="background: transparent; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-tablet-1" style="width: 13%; height: 95px;">
																			<style>
	.sno-hac-inner-tablet-1 {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-tablet-1 .sno-hac-menu-icon {
		font-size: 26px;
		line-height: calc(46px - (2 * 1px));
		height: calc(46px - (2 * 1px));
		width: 46px;
		border: 1px solid #ffffff;
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-tablet-1 .sno-hac-menu-icon:hover {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu {
		position: absolute;
		right: 0;
		top: 95px;
		left: 0;
		background: #444444;
		font-family: Oswald;
		font-weight: normal;
		text-transform: capitalize; 
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sno-hac-menu-mobile-name a,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sno-hac-menu-mobile-close {
		color: #ffffff;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sno-hac-menu-mobile-close:hover,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sno-hac-menu-mobile-name a:hover {
		background: #393939;
		color: #ffffff;
	}

	.sno-hac-hamburger-menu-tablet-1-mobile-menu li,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu ul ul {
		background: #ffffff;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu li a:hover {
		background: #393939;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu li:hover {
		background: #b3b3b3;
	}

	.sno-hac-hamburger-menu-tablet-1-mobile-menu ul li a,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu ul li a:focus {
		background: #444444;
		color: #ffffff;
		line-height: 32px;
		font-size: 16px;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu a:hover,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu a:focus:hover {
		background: #393939;
		color: #ffffff;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sf-arrows > li > .sf-with-ul:after,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sf-arrows > li > .sf-with-ul:after,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sf-arrows > .sf-with-ul:after {
		border-top-color: #ffffff;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sf-arrows > li > .sf-with-ul:focus:after,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sf-arrows > li:hover > .sf-with-ul:after,
	.sno-hac-hamburger-menu-tablet-1-mobile-menu sf-arrows > .sfHover > .sf-with-ul:after {
		border-top-color: #ffffff; 
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu li li {
		line-height: 32px;
		text-align: left;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu li li a {
		line-height: 32px;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu ul.sf-menu > li {
		float: none;
		display: inline-block;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu ul.sf-menu {
		float: none;
		text-align: center;
	}
	@media only screen and (max-width: 800px) {
		.sno-hac-hamburger-menu-tablet-1-mobile-menu {
			padding: 15px;
		}
		.sno-hac-hamburger-menu-tablet-1-mobile-menu li {
			border-bottom: none;
		}
		.sno-hac-hamburger-menu-tablet-1-mobile-menu ul li:hover ul { display: none; }
		.sno-hac-hamburger-menu-tablet-1-mobile-menu ul li li:last-of-type { border-bottom: none; }
		.sno-hac-hamburger-menu-tablet-1-mobile-menu ul > li.menu-item-has-children > a:after { 
			border-top-color: #ffffff;
		}
		.sno-hac-hamburger-menu-tablet-1-mobile-menu ul > li.menu-item-has-children:hover > a:after { 
			border-top-color: #ffffff;
		}
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu li a {
		white-space: nowrap;
		overflow: hidden;
		text-overflow: ellipsis;
	}
	.sno-hac-hamburger-menu-tablet-1-mobile-menu .sno-hac-menu-mobile-graphic img {
		object-fit: contain;
	}


</style>
<div class="sno-hac-inner sno-hac-inner-tablet-1">
	<div class="sno-hac-textwrap sno-menu-center-v">
		<button class="sno-hac-menu-icon" data-menu-id="tablet-1-mobile-menu">
			<i class="fas fa-bars"></i>
		</button>
	</div>
</div>
<div class="sno-hac-hamburger-menu sno-hac-hamburger-menu-tablet-1-mobile-menu">
	<nav aria-label="Navigation Menu">
		<div class="sno-hac-menu-wrap">
			<div class="sno-hac-menu-mobile-header">
				<div class="sno-hac-menu-mobile-close">
					<i class="fas fa-times"></i>
				</div>
									<div class="sno-hac-menu-mobile-name">
						<a href="https://www.talonmarks.com/">
							Talon Marks						</a>
					</div>
							</div>
			<div class="menu-bottom-menu-container"><ul id="menu-bottom-menu" class="sf-menu"><li id="menu-item-176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-176"><a href="https://www.talonmarks.com/category/news/">News</a></li>
<li id="menu-item-175" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-175"><a href="https://www.talonmarks.com/category/opinion/">Opinion</a></li>
<li id="menu-item-173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173"><a href="https://www.talonmarks.com/category/arts-entertainment/arts/">Arts</a></li>
<li id="menu-item-177" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-177"><a href="https://www.talonmarks.com/category/sports/">Sports</a></li>
<li id="menu-item-358" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-358"><a href="https://www.talonmarks.com/sports-center/">Sports Center</a></li>
<li id="menu-item-357" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-357"><a href="https://www.talonmarks.com/videos/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li id="menu-item-356" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-356"><a href="https://www.talonmarks.com/videos/">Videos</a></li>
	<li id="menu-item-355" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-355"><a href="https://www.talonmarks.com/videos/multimedia/slideshows/">Slideshows</a></li>
</ul>
</li>
</ul></div>			<ul class='sno-menu-more sf-arrows' style='display:none'>
				<li class="menu-more-item-top">
					<a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"></span></a>
					<ul class="sno-hac-menu-more"</ul>
				</li>
			</ul>
		</div>
	</nav>
</div>
																	</div>
																																																							<div class="sno-designer-area-container sno-hac-tablet-2" style="width: 74%; height: 95px;">
																			<style>
	.sno-hac-inner-tablet-2 {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-tablet-2 h1 {
		text-align: center;
		color: #000000;
		padding: 0 15px;
		font-size: 24px;
		font-family: Oswald;
		font-weight: 400;
		margin-bottom: 0;
	}
	.sno-hac-inner-tablet-2 .sno-hac-textwrap {
		position: absolute;
		top: 50%;
		transform: translateY(-50%);
		left: 0;
		right: 0;
	}
	.sno-hac-inner-tablet-2 h1 {
		margin-top: 0;
	}
	.sno-hac-inner-tablet-2 .sno-hac-headerimage {
		object-fit: contain;
	}
</style>
<a href="https://www.talonmarks.com/">
	<div class="sno-hac-inner sno-hac-inner-tablet-2">
				<img src="https://www.talonmarks.com/wp-content/uploads/2017/09/tablet.png" class="sno-hac-headerimage" alt="Cerritos College • Norwalk, Calif." />
		<div class="sno-hidden-title">
			<h1>Talon Marks</h1>
		</div>
		</div>
</a>																	</div>
																																																							<div class="sno-designer-area-container sno-hac-tablet-3" style="width: 13%; height: 95px;">
																			<style>
	.sno-hac-inner-tablet-3 {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-tablet-3 .sno-hac-search-icon {
		font-size: 26px;
		line-height: calc(46px - (2 * 1px));
		height: calc(46px - (2 * 1px));
		width: 46px;
		border: 1px solid #ffffff;
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-tablet-3 .sno-hac-search-icon:hover {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-search-icon-bar-tablet-3 {
		position: absolute;
		right: 0;
		top: 95px;
		left: 0;
		background: #444444;
		font-family: Oswald;
		height: 72px;
	}
	.sno-hac-search-icon-bar-tablet-3 .sno-hac-search-inner-wrap {
		width: calc(502px + (2 * 8px));
	}
	.sno-hac-search-icon-bar-tablet-3 .sno-hac-submit-search-button {
		right: 8px;
		font-size: 16px;
		top: 8px;
		bottom: 8px;
		width: 32px;
	}
	.sno-hac-search-icon-bar-tablet-3 input.hac-search {
		font-size: 16px;
		line-height: 32px;
		height: 32px;
		padding: 8px;
		border: 1px solid #000000;
		max-width: calc(100% - (8px * 2) - (1px * 2));
	}
</style>
<div class="sno-hac-inner sno-hac-inner-tablet-3">
	<div class="sno-hac-textwrap sno-search-center-v">
		<button class="sno-hac-search-icon" data-id="tablet-3">
			<i class="fas fa-search"></i>
		</button>
	</div>
</div>
<div class="sno-hac-search-icon-bar sno-hac-search-icon-bar-tablet-3">
	<div class="sno-hac-textwrap sno-hac-center-v">
		<form method="get" action="https://www.talonmarks.com/">
			<div class="sno-hac-search-inner-wrap">
				<label for="s-tablet-3" class="assistive-text">Search this site</label>
				<input type="text" class="field hac-search" name="s" id="s-tablet-3" placeholder="Enter Search Term" />
				<button type="submit" class="sno-hac-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
		</form>
	</div>
</div>
																	</div>
																					</div>
					</div>
					<div class="clear"></div>
										</div>
					<div class="sno-header-wrap sno-header-wrap-mobile">
																																																																																																															<div class="sno-designer-area-row sno-designer-area-row-mobile-1" style="background: transparent; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-mobile-1" style="width: 18%; height: 80px;">
																			<style>
	.sno-hac-inner-mobile-1 {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-mobile-1 .sno-hac-menu-icon {
		font-size: 26px;
		line-height: calc(46px - (2 * 1px));
		height: calc(46px - (2 * 1px));
		width: 46px;
		border: 1px solid #ffffff;
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-mobile-1 .sno-hac-menu-icon:hover {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu {
		position: absolute;
		right: 0;
		top: 80px;
		left: 0;
		background: #444444;
		font-family: Oswald;
		font-weight: normal;
		text-transform: capitalize; 
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sno-hac-menu-mobile-name a,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sno-hac-menu-mobile-close {
		color: #ffffff;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sno-hac-menu-mobile-close:hover,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sno-hac-menu-mobile-name a:hover {
		background: #393939;
		color: #ffffff;
	}

	.sno-hac-hamburger-menu-mobile-1-mobile-menu li,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu ul ul {
		background: #ffffff;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu li a:hover {
		background: #393939;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu li:hover {
		background: #b3b3b3;
	}

	.sno-hac-hamburger-menu-mobile-1-mobile-menu ul li a,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu ul li a:focus {
		background: #444444;
		color: #ffffff;
		line-height: 32px;
		font-size: 16px;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu a:hover,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu a:focus:hover {
		background: #393939;
		color: #ffffff;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sf-arrows > li > .sf-with-ul:after,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sf-arrows > li > .sf-with-ul:after,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sf-arrows > .sf-with-ul:after {
		border-top-color: #ffffff;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sf-arrows > li > .sf-with-ul:focus:after,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sf-arrows > li:hover > .sf-with-ul:after,
	.sno-hac-hamburger-menu-mobile-1-mobile-menu sf-arrows > .sfHover > .sf-with-ul:after {
		border-top-color: #ffffff; 
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu li li {
		line-height: 32px;
		text-align: left;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu li li a {
		line-height: 32px;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu ul.sf-menu > li {
		float: none;
		display: inline-block;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu ul.sf-menu {
		float: none;
		text-align: center;
	}
	@media only screen and (max-width: 800px) {
		.sno-hac-hamburger-menu-mobile-1-mobile-menu {
			padding: 15px;
		}
		.sno-hac-hamburger-menu-mobile-1-mobile-menu li {
			border-bottom: none;
		}
		.sno-hac-hamburger-menu-mobile-1-mobile-menu ul li:hover ul { display: none; }
		.sno-hac-hamburger-menu-mobile-1-mobile-menu ul li li:last-of-type { border-bottom: none; }
		.sno-hac-hamburger-menu-mobile-1-mobile-menu ul > li.menu-item-has-children > a:after { 
			border-top-color: #ffffff;
		}
		.sno-hac-hamburger-menu-mobile-1-mobile-menu ul > li.menu-item-has-children:hover > a:after { 
			border-top-color: #ffffff;
		}
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu li a {
		white-space: nowrap;
		overflow: hidden;
		text-overflow: ellipsis;
	}
	.sno-hac-hamburger-menu-mobile-1-mobile-menu .sno-hac-menu-mobile-graphic img {
		object-fit: contain;
	}


</style>
<div class="sno-hac-inner sno-hac-inner-mobile-1">
	<div class="sno-hac-textwrap sno-menu-center-v">
		<button class="sno-hac-menu-icon" data-menu-id="mobile-1-mobile-menu">
			<i class="fas fa-bars"></i>
		</button>
	</div>
</div>
<div class="sno-hac-hamburger-menu sno-hac-hamburger-menu-mobile-1-mobile-menu">
	<nav aria-label="Navigation Menu">
		<div class="sno-hac-menu-wrap">
			<div class="sno-hac-menu-mobile-header">
				<div class="sno-hac-menu-mobile-close">
					<i class="fas fa-times"></i>
				</div>
									<div class="sno-hac-menu-mobile-name">
						<a href="https://www.talonmarks.com/">
							Talon Marks						</a>
					</div>
							</div>
			<div class="menu-bottom-menu-container"><ul id="menu-bottom-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-176"><a href="https://www.talonmarks.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-175"><a href="https://www.talonmarks.com/category/opinion/">Opinion</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-173"><a href="https://www.talonmarks.com/category/arts-entertainment/arts/">Arts</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-177"><a href="https://www.talonmarks.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-358"><a href="https://www.talonmarks.com/sports-center/">Sports Center</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-357"><a href="https://www.talonmarks.com/videos/multimedia/">Multimedia</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-356"><a href="https://www.talonmarks.com/videos/">Videos</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-355"><a href="https://www.talonmarks.com/videos/multimedia/slideshows/">Slideshows</a></li>
</ul>
</li>
</ul></div>			<ul class='sno-menu-more sf-arrows' style='display:none'>
				<li class="menu-more-item-top">
					<a href="/" class="sf-with-ul">More<span class="sf-sub-indicator"></span></a>
					<ul class="sno-hac-menu-more"</ul>
				</li>
			</ul>
		</div>
	</nav>
</div>
																	</div>
																																																							<div class="sno-designer-area-container sno-hac-mobile-2" style="width: 64%; height: 80px;">
																			<style>
	.sno-hac-inner-mobile-2 {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-mobile-2 h1 {
		text-align: center;
		color: #000000;
		padding: 0 15px;
		font-size: 24px;
		font-family: Oswald;
		font-weight: 400;
		margin-bottom: 0;
	}
	.sno-hac-inner-mobile-2 .sno-hac-textwrap {
		position: absolute;
		top: 50%;
		transform: translateY(-50%);
		left: 0;
		right: 0;
	}
	.sno-hac-inner-mobile-2 h1 {
		margin-top: 0;
	}
	.sno-hac-inner-mobile-2 .sno-hac-headerimage {
		object-fit: contain;
	}
</style>
<a href="https://www.talonmarks.com/">
	<div class="sno-hac-inner sno-hac-inner-mobile-2">
				<img src="https://www.talonmarks.com/wp-content/uploads/2017/09/phone.png" class="sno-hac-headerimage" alt="Cerritos College • Norwalk, Calif." />
		<div class="sno-hidden-title">
			<h1>Talon Marks</h1>
		</div>
		</div>
</a>																	</div>
																																																							<div class="sno-designer-area-container sno-hac-mobile-3" style="width: 18%; height: 80px;">
																			<style>
	.sno-hac-inner-mobile-3 {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-mobile-3 .sno-hac-search-icon {
		font-size: 26px;
		line-height: calc(46px - (2 * 1px));
		height: calc(46px - (2 * 1px));
		width: 46px;
		border: 1px solid #ffffff;
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-inner-mobile-3 .sno-hac-search-icon:hover {
		background: #ffffff;
		color: #000000;
	}
	.sno-hac-search-icon-bar-mobile-3 {
		position: absolute;
		right: 0;
		top: 80px;
		left: 0;
		background: #444444;
		font-family: Oswald;
		height: 72px;
	}
	.sno-hac-search-icon-bar-mobile-3 .sno-hac-search-inner-wrap {
		width: calc(502px + (2 * 8px));
	}
	.sno-hac-search-icon-bar-mobile-3 .sno-hac-submit-search-button {
		right: 8px;
		font-size: 16px;
		top: 8px;
		bottom: 8px;
		width: 32px;
	}
	.sno-hac-search-icon-bar-mobile-3 input.hac-search {
		font-size: 16px;
		line-height: 32px;
		height: 32px;
		padding: 8px;
		border: 1px solid #000000;
		max-width: calc(100% - (8px * 2) - (1px * 2));
	}
</style>
<div class="sno-hac-inner sno-hac-inner-mobile-3">
	<div class="sno-hac-textwrap sno-search-center-v">
		<button class="sno-hac-search-icon" data-id="mobile-3">
			<i class="fas fa-search"></i>
		</button>
	</div>
</div>
<div class="sno-hac-search-icon-bar sno-hac-search-icon-bar-mobile-3">
	<div class="sno-hac-textwrap sno-hac-center-v">
		<form method="get" action="https://www.talonmarks.com/">
			<div class="sno-hac-search-inner-wrap">
				<label for="s-mobile-3" class="assistive-text">Search this site</label>
				<input type="text" class="field hac-search" name="s" id="s-mobile-3" placeholder="Enter Search Term" />
				<button type="submit" class="sno-hac-submit-search-button sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
			</div>
		</form>
	</div>
</div>
																	</div>
																					</div>
					</div>
					<div class="clear"></div>
										</div>
						<div id="fullwrap">
			<div class="innerbackgroundwrap">
				<div class="innerbackground"><div id='snopostid-10055859' class='snopostid'><div id='classic_story' class='sno-story-10055859'><div id="content"><div id='contentleft'><div class="postarea"><ul class="snocategories"><li class='blockscategory'><a href='https://www.talonmarks.com/category/sports/football/' rel='category tag'>Football</a></li><li class='blockscategory'><a href='https://www.talonmarks.com/category/columns/off-the-field/' rel='category tag'>Off the Field</a></li><li class='blockscategory'><a href='https://www.talonmarks.com/category/sports/' rel='category tag'>Sports</a></li></ul><div role="main"><h1 class="storyheadline">Off The Field: Worst NFL coach Urban Meyer</h1><div class="clear"></div><div class="permalinkphotobox"></div><div class="storydetails"><p><span class="storybyline"> <a href="https://www.talonmarks.com/staff_name/silas-bravo/" class="creditline">Silas Bravo</a>, Staff Writer</span><br /><span class="storydate"><span class="time-wrapper">December 19, 2021</span></span></p></div><span class="storycontent"><p><span style="font-weight: 400;">This is Urban Meyer’s first year ever coaching in the NFL and it is safe to say that he will go down as one of the worst NFL coaches ever. </span></p>
<p><span style="font-weight: 400;">The firing comes right after former Jaguars’ kicker Josh Lambo accused Meyer of kicking him before a game as well as verbally attacking him. </span></p>
<p><span style="font-weight: 400;">Meyer apparently cussed Lambo out while demanding him to make his kicks. Lambo was cut not too long after. </span></p>
<p><span style="font-weight: 400;">Meyer claims that the story is inaccurate but whether it is true or not Meyer has been in controversy all throughout his NFL tenure. </span></p>
<p><span style="font-weight: 400;">The former Jaguars head coach started off his year by hiring a strength and conditioning coach who had a history of being accused of making racial remarks and bullying African American players. </span></p>
<p><span style="font-weight: 400;">The Jaguars had some more drama when Meyer signed his former Heisman winning quarterback Tim Tebow to play tight end, a position in which he never played.</span></p>
<p><span style="font-weight: 400;">Jacksonville and Meyer were also fined by the NFL during the summer for excessive contact and violating COVID-19 protocols. </span></p>
<p><span style="font-weight: 400;">Meyer’s lowest point in the season had to be when a video went viral of him dancing with a woman who was not his wife in a bar. Meyer did not travel back with his team after a loss to the Cincinnati Bengals and instead claimed he would visit Columbus to visit his grandchildren.</span></p>
<p><span style="font-weight: 400;">Owner Shad Khan had warned Meyer of his inexcusable behavior, but it seems he did not get the message.</span></p>
<p><span style="font-weight: 400;">Meyer often clashed with his staff and players throughout the season as well. </span></p>
<p><span style="font-weight: 400;">Wide receiver Marvin Jones Jr. apparently had to be persuaded to return to his team after leaving in response to the public criticism from his former head coach.</span></p>
<p><span style="font-weight: 400;">Meyer denied these reports, however the countless controversies along with the terrible play from his team were just too much.</span></p>
<p><span style="font-weight: 400;">The Jaguars are 2-11 and have barely been competitive. </span></p>
<p><span style="font-weight: 400;">Number 1 overall pick Trevor Lawrence has looked awful under Meyer’s system. </span></p>
<p><span style="font-weight: 400;">Running back James Robinson was benched two weeks ago against the Los Angeles for fumbling in back-to-back games. </span></p>
<p><span style="font-weight: 400;">Robinson had a spectacular rookie year, rushing for over 1000 yards in 2020. </span></p>
<p><span style="font-weight: 400;">Meyer and his assistant coaches are another reason Meyer was let go. Meyer had a history of being hard on his coaches at Ohio St., and it seems this carried on to the NFL.</span></p>
<p><span style="font-weight: 400;">Assistants were not big fans of the way Meyer treated them, as well as how he would make them stay overnight to prepare for games. A lot of coaches and staff departed mid-year.</span></p>
<p><span style="font-weight: 400;">An Urban Meyer fan or not it is obvious it was time for Jacksonville to move on from the former Buckeye. </span></p>
<p><span style="font-weight: 400;">Meyer’s college football tenure was full of controversy as well, however Meyer won three National Championships.</span></p>
<p><span style="font-weight: 400;">Hopefully the Jaguars can find anything positive from this season and end the year strong. </span></p>
</span><div class="clear"></div></div><ul class="snotags"><li class="blockstag"><a href="https://www.talonmarks.com/tag/jaguars/" rel="tag">Jaguars</a></li><li class="blockstag"><a href="https://www.talonmarks.com/tag/nfl/" rel="tag">nfl</a></li><li class="blockstag"><a href="https://www.talonmarks.com/tag/sports-opinion/" rel="tag">Sports opinion</a></li><li class="blockstag"><a href="https://www.talonmarks.com/tag/urban-meyer/" rel="tag">Urban Meyer</a></li></ul></div><div class="aboutwriter"><div class='aboutwritertitle'>About the Writer</div>
<!-- profile displayed from cache -->
<div class='storycreditboxwide'><div class='sc_photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/08/Silas-Bravo.jpg' alt='Photo of Silas Bravo'/></div><a href="https://www.talonmarks.com/staff_profile/silas-bravo/"><div class='sc_title'>Silas Bravo, Staff Writer</div></a><div class='sc_bio'>Silas Bravo is a staff writer and a student athlete at Cerritos College. He hopes to receive an athletic scholarship to continue his football career at a university. Silas enjoys watching and playing sports, spending time with friends and family as well as working out.<div class='clear'></div></div></div><div class="clear"></div></div></div><div id="sidebar" class="sidebar-template"><!-- Size: 11 -->
<div class='snoadnetwork'>
	<div class='sidebar-ad'>
		<script type="text/javascript">
			jQuery(document).ready(function( $ ) {
				retreive_ad();
				$('.sidebar-ad').on('click', '.sno-ad', function() {
					let ad_id = $(this).data('ad-id');
					url = 'https://snoads.com/api/v1/ad/' + ad_id + '/click';
					jQuery.post(url, '', function(response) {
						console.log(response);
			        });
				});
				$('.sidebar-ad').on('click', '.sno-fill-ad', function() {
					url = 'https://snoads.com/site/69';
					window.open(url, '_blank');
				});
		        function retreive_ad() {
		        	var url = 'https://snoads.com/api/v1/adspot/96/serve'
		        	var fill_ad = "";
					jQuery.get(url, '', function(response) {
						if (response) {
							$('.sidebar-ad').html('<a target="_blank" href="' + response.link.link + '" class="sno-ad" data-ad-id="' + response.id + '"><img src="' + response.image.url + '" alt="Advertisement" /></a>');
						} else if (fill_ad) {
							$('.sidebar-ad').html('<img class="sno-fill-ad" src="' + fill_ad + '" alt="Advertisement" />');
						} else {
							let rand_num = Math.floor((Math.random() * 3) + 1);
							$('.sidebar-ad').html('<img class="sno-fill-ad" src="https://snoads.s3.amazonaws.com/sno_ad_fill/300x250_' + rand_num + '.jpg" alt="Advertisement" />');
						}
			        });
		        }
			});
		</script>
	</div>
</div><section><div class="widgetwrap sno-animate"><div></div><div class="titlewrap" role="heading"><div class="widgettitle-nonsno">Subscribe</div></div><div class="widgetbody"><figure style="width: 300px" class="wp-caption alignnone"><a href="https://www.talonmarks.com/subscribe/"><img width="300" height="250" src="https://www.talonmarks.com/wp-content/uploads/2021/10/Newsletter-AD-Square-300x250-px.png" class="image wp-image-10055179  attachment-full size-full" alt="" loading="lazy" style="max-width: 100%; height: auto;" title="Subscribe" /></a><figcaption class="wp-caption-text">Sign up for Talon Marks Weekly Newsletter</figcaption></figure></div></div></section>
			<style>
				.sno-trending-3 .trending-number, .sno-trending-3 .trending-views { color: #000000; }
				.sno-trending-3 .sno-trending-card-teaser { font-size: 14px; line-height: 21px; }
																				/* 						.sno-trending-3 .widgetbody { padding: 0px !important; } */
							</style>
			<section>
	<div class="widgetwrap sno-animate sno-trending-3 widget-shadow">
		<div class="widget6 widgettitle" role="heading">
	Trending Stories</div>
<div class="clear"></div>
<div class="widgetbody6 widgetbody">
				<div class=" sno-widget-trending-wrapper" style="background: #ffffff; padding-top: 1px; border-left: 1px solid #ffffff; border-right: 1px solid #ffffff;">
	
					
<!-- widget displayed from cache -->
<div class="trending-row-wrap" style="background: #f7f7f7; color: #000000; margin-bottom: 1px;"><a href="https://www.talonmarks.com/community/2021/12/15/santas-landing-in-norwalk-town-square-gives-community-pre-pandemic-nostalgia/" title="Santa returns to Norwalk Town Square holiday festival"><div class='trending-row'><div class="trending-number">1</div><div class="trending-image"><img src="https://www.talonmarks.com/wp-content/uploads/2021/12/DSC_0002.NEF_-300x192.jpg" alt="Santa lands in the Norwalk town square for their annual Christmas festival. The event was canceled last year but was able to be held on Dec. 11, 2021." class="trending-thumbnail"/></div><div class="trendingheadline"><p><span class='th_link homeheadline'>Santa returns to Norwalk Town Square holiday festival</span><span class="trending-views">  &bull;  383 Views</span></p></div><div class="clear"></div></div></a></div><div class="trending-row-wrap" style="background: #f7f7f7; color: #000000; margin-bottom: 1px;"><a href="https://www.talonmarks.com/sports/2021/12/16/lincoln-riley-hire-proves-beneficial-for-usc/" title="Lincoln Riley hire proves beneficial for USC"><div class='trending-row'><div class="trending-number">2</div><div class="trending-image"><img src="https://www.talonmarks.com/wp-content/uploads/2021/12/tommy-trojan-300x225.jpg" alt="USCs hire of Lincoln Riley proves beneficial for the University. Photo credit: Ken Lund" class="trending-thumbnail"/></div><div class="trendingheadline"><p><span class='th_link homeheadline'>Lincoln Riley hire proves beneficial for USC</span><span class="trending-views">  &bull;  381 Views</span></p></div><div class="clear"></div></div></a></div><div class="trending-row-wrap" style="background: #f7f7f7; color: #000000; margin-bottom: 1px;"><a href="https://www.talonmarks.com/sports/2021/12/14/off-the-field-warriors-lead-with-best-record-in-nba/" title="Off The Field: Warriors are unbeatable force this season"><div class='trending-row'><div class="trending-number">3</div><div class="trending-image"><img src="https://www.talonmarks.com/wp-content/uploads/2021/12/sports-bkn-76ers-curry-ph-300x200.jpg" alt="Philadelphia 76ers Seth Curry guards his brother, Golden State Warriors point guard Stephen Curry, during the fourth quarter at the Wells Fargo Center on Monday, April 19, 2021 in Philadelphia." class="trending-thumbnail"/></div><div class="trendingheadline"><p><span class='th_link homeheadline'>Off The Field: Warriors are unbeatable force this season</span><span class="trending-views">  &bull;  98 Views</span></p></div><div class="clear"></div></div></a></div><div class="clear"></div>				
				</div>

								<div class="clear"></div>
			</div>
				</div>
</section>

					<style>
									.sno-sno_text-22 .widgetbody { padding-left: 0px; padding-right: 0px; }
							</style>
			<section>
	<div class="widgetwrap sno-animate sno-sno_text-22">
					<div class="snotextwidget">		

									<a class="twitter-timeline" data-height="300" data-dnt="true" href="https://twitter.com/TalonMarks">Tweets by TalonMarks</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>							
			</div>
								<div class="clear"></div>
		</div>
</section>
					<style>
							</style>
			<section>
	<div class="widgetwrap sno-animate sno-sno_text-16 widget-shadow">
					<div class="snotextwidget">		

									<div id="CampusAveAPI_Recent_Listings_Container" partnerid="17" format="large">Loading Recent Classifieds...</div> <script type="text/javascript" src="https://www.campusave.com/includes/api.recent.js"></script>							
			</div>
								<div class="clear"></div>
		</div>
</section>
		</div></div></div></div><div class="sno_teaserbar" id="sno_teaserbar"><div class="stb_nav"><div class="custom-navigation"><span class="flex-prev"><div class="stb_left"><div class="fa fa-angle-left"><div class="icon-hidden-text">Navigate Left</div></div></div></span></div></div><div id='stb-container' class='flexslider'><ul class="slides"><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/12/16/lincoln-riley-hire-proves-beneficial-for-usc/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/12/tommy-trojan-475x356.jpg' id='grow-stb10055848'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='USCs hire of Lincoln Riley proves beneficial for the University. Photo credit: Ken Lund'/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/12/16/lincoln-riley-hire-proves-beneficial-for-usc/">Lincoln Riley hire proves beneficial for USC</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/12/07/2021falcon-football-season-recap/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/12/Featured-Photo-475x317.jpg' id='grow-stb10055769'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Freshman running back No. 6, Davon Booth rushes to the left pylon and breaks a tackle to score the Falcon’s first touchdown of the game against the Hornets on Sept. 11, 2021. Photo by: Roman Acosta'/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/12/07/2021falcon-football-season-recap/">2021 Falcon football season recap</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/11/25/off-the-field-odell-beckham-to-the-rams-is-a-smart-move/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/11/sports-fbn-rams-woods-1st-lede-la-475x349.jpg' id='grow-stb10055721'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Los Angeles Rams wide receiver Robert Woods (2) runs out of bounds after making a catch against the Detroit Lions at SoFi Stadium in Inglewood, California, on  Oct. 24, 2021. (Luis Sinco/Los Angeles Times/TNS)'/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/11/25/off-the-field-odell-beckham-to-the-rams-is-a-smart-move/">Off The Field: Odell Beckham to the Rams is a smart move</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/11/24/cerritos-shreds-southwestern-in-their-final-home-game-of-the-season/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/11/No.-8-run-475x317.jpg' id='grow-stb10055665'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Sophomore running back No. 8, J’Lon Manning takes the handoff against Southwestern’s defense in the second quarter alongside Sophomore wide receiver No. 3, DeJour Smith out in front lead blocking. Manning finished with 11 carries for 82 yards against the Jaguars on Nov. 20, 2021. '/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/11/24/cerritos-shreds-southwestern-in-their-final-home-game-of-the-season/">Cerritos shreds Southwestern in their final home game of the season</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/11/09/falcons-lose-another-heartbreaker-to-riverside/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/11/10-475x316.jpg' id='grow-stb10055510'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Sophomore wide receiver No. 10, Bailey Torres takes the handoff on an outside zone sweep on the Falcon’s second offensive possession. Torres takes the ball to the 1-yard line as he is stopped by a Tigers defender on Nov. 6. '/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/11/09/falcons-lose-another-heartbreaker-to-riverside/">Riverside Tigers maul Falcons, fight breaks out after game</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/11/02/falcons-lose-to-game-winning-field-goal-by-palomar/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/11/Cade-475x317.jpg' id='grow-stb10055452'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Freshman Quarterback No.11 Cade McConnell rolls out to his right to avoid the Palomar defender. McConnell finds a Cerritos receiver down the field after having just thrown the ball to avoid the sack on Oct. 30, 2021. '/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/11/02/falcons-lose-to-game-winning-field-goal-by-palomar/">Falcons lose to game-winning field goal by Palomar</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/10/27/cerritos-falcons-defeat-el-camino-in-annual-milk-can-game/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/10/CC-Sideline--475x316.jpg' id='grow-stb10055346'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='The Cerritos Offense heads to the sideline after Running Back Davon Booth #6 Scores the first Touchdown of the game for the Falcons. Several Cerritos players are seen high-fiving teammates and coaches as they make their way towards the sideline in the first quarter of the game on Oct. 23, 2021. '/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/10/27/cerritos-falcons-defeat-el-camino-in-annual-milk-can-game/">Cerritos Falcons defeat El Camino in annual Milk Can game</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/10/21/falcons-soar-over-chaffey-panthers/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/10/Feature-475x316.jpg' id='grow-stb10055272'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Falcons RB Penieli Lauago (#25) is lifting into the air by OL Jonathan Manzo (#54). Penieli caught a 37-yard touchdown pass to give the Falcons at 33-17 lead in the 4th quarter of their game at Chaffey College on October 16th. '/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/10/21/falcons-soar-over-chaffey-panthers/">Falcons soar over Chaffey Panthers</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/09/15/cerritos-falcons-lose-to-fullerton-hornets/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/09/Bailey-Torres-Jump-ball-10-475x331.jpg' id='grow-stb10054757'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Falcons Wide Receiver Bailey Torres Jumps up in an attempt to make the catch. He is in coverage against a Fullerton Defensive back during the game on Sept. 11, 2021. '/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/09/15/cerritos-falcons-lose-to-fullerton-hornets/">Falcons stung by Fullerton Hornets</a></p></li><li class='stb-top-row'><div class='stb_image'><a href='https://www.talonmarks.com/sports/2021/08/28/off-the-field-five-years-after-kaepernick-kneeling/#photo'><img src='https://www.talonmarks.com/wp-content/uploads/2021/08/45032875661_b68ff63205_o-475x356.jpg' id='grow-stb10054602'  style='height:70px;min-height:70px;width:auto;' class='catboxphoto' alt='Colin Kaepernick billboard for ad campaign near Maddison Square Garden in New York. Photo credit: Brecht Bug/Flickr'/></a></div><p class='stb-cat'>Football</p><p class="relatedtitle"><a href="https://www.talonmarks.com/sports/2021/08/28/off-the-field-five-years-after-kaepernick-kneeling/">Off The Field: Five years after Kaepernick kneeling</a></p></li></ul></div><div class="stb_nav"><div class="custom-navigation"><span class="flex-next"><div class="stb_right"><div class="fa fa-angle-right"><div class="icon-hidden-text">Navigate Right</div></div></div></span></div></div></div><div class="clear"></div><script type="text/javascript" charset="utf-8">
		jQuery(document).ready(function() {
			jQuery('#stb-container').flexslider({
				animation: "slide",
				animationLoop: true,
				customDirectionNav: jQuery(".stb_nav .custom-navigation span"), 
       			slideshow: false,
				itemMargin: 2,
				touch: true,
				itemWidth: 300,
				minItems: 1,
				move: 1,
				maxItems: 5
  			});

		});

			jQuery(document).ready(function(){
			
			var TB_CurrentScroll = 0; var TB_NextScroll = 0; var hbheight = 0;
			
			
			jQuery(window).scroll(function(event) {
				TB_CurrentScroll = TB_NextScroll;
				if (jQuery('#sno_hoverbar').is(":visible")) { hbheight = 50 }
				TB_NextScroll = jQuery(this).scrollTop();
				if (TB_NextScroll < TB_CurrentScroll && jQuery(document).scrollTop() > 500) {  // scrolling up on the page causes it to display
					if (jQuery('.sno_teaserbar').is(":hidden")) {
						jQuery('.sno_teaserbar').show();
						jQuery('.sno_teaserbar').stop().animate({ top: hbheight }, { duration: 300, queue: false });
					}
				}
				 else if ((TB_NextScroll > TB_CurrentScroll && jQuery(document).scrollTop() > 500) || jQuery(document).scrollTop() < 400 ){ // scrolling down on the page causes it to hide
					jQuery('.sno_teaserbar').stop().animate({
						top: '-86px'
						},200, function(){
							jQuery('.sno_teaserbar').hide();
						});
				} 
			});
				});
	</script>					</div>
				</div>
			</div>
			<div style="clear:both;"></div>
			<div class="footer footer_single">
																					<div class="sno-footer-wrap sno-footer-wrap-desktop-footer">
																																																																																																																											<div class="sno-designer-area-row sno-designer-area-row-desktop-footer-1" style="background: transparent; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-desktop-footer-1" style="width: 100%; height: 131px;">
																			<style>
	.sno-hac-inner-desktop-footer-1 {
		background: transparent;
		text-align: center;
	}
	.sno-hac-inner-desktop-footer-1 .sno-hac-adwrap {
		border: 0px solid #eeeeee;
	}
	.sno-hac-inner-desktop-footer-1 .sno-hac-adgroup-wrap .snoadrotatewidgetwrap {
		height: 131px;
		width: 100%;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-footer-1">
	<div class="sno-hac-textwrap sno-hac-center-v">
					<div class="sno-hac-adwrap">
				<div class="footeradboardwrap">
	<div class="footeradboard">
		<div class="footerad snoads_footerad" data-ad_spot_id="99" data-ad_fill="" data-sno_ads_id="69"></div>
	</div>
</div>			</div>
			</div>
</div>																	</div>
																					</div>
					</div>
					<div class="clear"></div>
																																																																					<div class="sno-designer-area-row sno-designer-area-row-desktop-footer-2" style="background: #0d0c0c; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-desktop-footer-2" style="width: 39%; height: 116px;">
																			<style>
	.sno-hac-inner-desktop-footer-2 {
		background: #002e66;
		color: #ffffff;
		overflow: hidden;
	}
	.sno-hac-inner-desktop-footer-2 h1 {
		text-align: left;
		color: #ffffff;
		padding: 0 15px;
		font-size: 28px;
		font-family: Oswald;
		font-weight: normal;
		margin-top: 10px;
		margin-bottom: 5px;
	}
	.sno-hac-inner-desktop-footer-2 p {
		text-align: left;
		padding: 0 15px;
		font-size: 18px;
		font-family: Oswald;
		font-weight: normal;
	}
</style>
<a href="https://www.talonmarks.com/">
	<div class="sno-hac-inner sno-hac-inner-desktop-footer-2">
		<div class="sno-hac-textwrap sno-hac-header-text">
			<h1>Talon Marks</h1>
					<p>Cerritos College • Norwalk, Calif.</p>
				</div>
	</div>
</a>																	</div>
																																																							<div class="sno-designer-area-container sno-hac-desktop-footer-3" style="width: 61%; height: 116px;">
																																																																																																																			<div class="sno-designer-area-row" style="min-height: 63px;">
																																																																																																																																																								<div class="sno-designer-area-container sno-hac-desktop-footer-4" style="width: 100%; height: 63px;">
														<style>
	.sno-hac-inner-desktop-footer-4 {
		background: #002e66;
		overflow: hidden;
		padding-left: 10px;
		padding-right: 10px;
		width: calc(100% - (2 * 10px));
	}
	.sno-hac-inner-desktop-footer-4 .sno-icon {
		height: 30px;
		width: 30px;
		line-height: 30px;
		font-size: calc(30px * 2 / 3);
		border-radius: 5px;
		margin-right: 5px;
		
	}
	.sno-hac-inner-desktop-footer-4 .sno-hac-iconwrap {
		text-align: right;
		margin-left: 0px;
	}
	.sno-hac-inner-desktop-footer-4 .sno-hac-iconwrap a:nth-of-type(16) .sno-icon {
		margin-right: 0;	
	}
	.sno-hac-inner-desktop-footer-4 .sno-hac-iconwrap a:nth-of-type(n + 17) {
		display: none;	
	}


	.sno-hac-inner-desktop-footer-4 .sno-icon {
		margin-top: 16.5px;
		margin-bottom: 16.5px;
	}
	.icon-monochromatic-desktop-footer-4 .sno-icon {
		background: #990000;
		color: #fff;
	} 
	.icon-monochromatic-inverse-hover-desktop-footer-4 .sno-icon:hover {
		color: #990000;
		background: #fff;
	}
	.icon-monochromatic-inverse-desktop-footer-4 .sno-icon {
		color: #990000;
		background: #fff;
	}
	.icon-monochromatic-hover-desktop-footer-4 .sno-icon:hover {
		background: #990000;
		color: #fff;
	}
	.icon-monochromatic-desktop-footer-4 .sno-icon i, .icon-monochromatic-inverse-desktop-footer-4 .sno-icon i {
		-webkit-text-stroke-width: 0px !important;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-footer-4 icon-standard-desktop-footer-4 icon-inverse-hover">
	<div class="sno-hac-iconwrap">
			<a target="_blank" href="https://facebook.com/talonmarks">
		<div class="sno-icon social-border sno-facebook">
    		<i class="fa fa-facebook-f"></i>
    		<span class="icon-hidden-text">Facebook</span>
    	</div>
	</a>

	<a target="_blank" href="https://twitter.com/talonmarks">
		<div class="sno-icon social-border sno-twitter">
    		<i class="fa fa-twitter"></i>
    		<span class="icon-hidden-text">Twitter</span>
    	</div>
	</a>

	<a target="_blank" href="https://www.instagram.com/talonmarks">
		<div class="sno-icon social-border sno-instagram">
    		<i class="fa fa-instagram"></i>
    		<span class="icon-hidden-text">Instagram</span>
    	</div>
	</a>









	<a target="_blank" href="https://www.snapchat.com/add/talonmarks">
		<div class="sno-icon social-border sno-snapchat">
    		<i class="fa fa-snapchat-ghost"></i>
    		<span class="icon-hidden-text">Snapchat</span>
    	</div>
	</a>

	<a target="_blank" href="https://www.youtube.com/user/talonmarksmedia">
		<div class="sno-icon social-border sno-youtube">
    		<i class="fa fa-youtube-play"></i>
    		<span class="icon-hidden-text">YouTube</span>
    	</div>
	</a>


	

	<a target="_blank" href="https://www.talonmarks.com/subscribe/">
		<div class="sno-icon social-border sno-email">
    		<i class="fa fa-envelope"></i>
    		<span class="icon-hidden-text">Email Signup</span>
    	</div>
	</a>

									
	<a target="_blank" href="https://www.talonmarks.com/feed/rss/">
    	<div class="sno-icon social-border sno-rss">
        	<i class="fa fa-rss"></i>
        	<span class="icon-hidden-text">RSS Feed</span>
        </div>
	</a>
	</div>
</div>


													</div>
																																																	</div>
																																																																																																		<div class="sno-designer-area-row" style="min-height: 53px;">
																																																																																																																																																								<div class="sno-designer-area-container sno-hac-desktop-footer-5" style="width: 34%; height: 53px;">
														<style>
	.sno-hac-inner-desktop-footer-5 {
		background: #002e66;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-footer-5"></div>													</div>
																																																																																																																																														<div class="sno-designer-area-container sno-hac-desktop-footer-6" style="width: 66.001%; height: 53px;">
														<style>
	.sno-hac-inner-desktop-footer-6 {
		background: #002e66;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-footer-6"></div>													</div>
																																																	</div>
																																																	</div>
																					</div>
					</div>
					<div class="clear"></div>
																																																																					<div class="sno-designer-area-row sno-designer-area-row-desktop-footer-3" style="background: #0d0c0c; ">
						<div class="sno-hac-row-wrap">
																																															<div class="sno-designer-area-container sno-hac-desktop-footer-7" style="width: 100%; height: 97px;">
																			<style>
	.sno-hac-inner-desktop-footer-7 {
		background: #002E66;
		border: 0px solid #eeeeee;
		margin: 10px;
	}
	.sno-hac-inner-desktop-footer-7 h1, 
	.sno-hac-inner-desktop-footer-7 h2, 
	.sno-hac-inner-desktop-footer-7 h3, 
	.sno-hac-inner-desktop-footer-7 h4, 
	.sno-hac-inner-desktop-footer-7 h5, 
	.sno-hac-inner-desktop-footer-7 h6, 
	.sno-hac-inner-desktop-footer-7 p,
	.sno-hac-inner-desktop-footer-7 {
		color: #ffffff;
		text-align: left;
		font-family: Oswald;
		font-weight: normal;
		font-style: normal;
	}
	.sno-hac-inner-desktop-footer-7 a, .sno-hac-inner-desktop-footer-7 a:hover, .sno-hac-inner-desktop-footer-7 a:visited {
		color: #ffffff;
	}
	.sno-hac-inner-desktop-footer-7,
	.sno-hac-inner-desktop-footer-7 p {
		font-size: 14px;
		line-height: 1.5em;
	}
	.sno-hac-inner-desktop-footer-7 {
		padding-top: 10px;
		height: calc(100% - 10px - (0px * 2) - (10px * 2));
	}
	.sno-hac-inner-desktop-footer-7 {
		padding-left: 10px;
		padding-right: 10px;
		width: calc(100% - 20px - (0px * 2) - (10px * 2));
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-footer-7">
			<div class="sno-hac-textwrap">
			Cerritos College<br />11110 Alondra Blvd. <br />Norwalk, CA 90650 <br />Contact Editor - 562-860-2451 x2618 or <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="5530313c213a27152134393a3b3834273e267b363a38">[email&#160;protected]</a>		</div>
	</div>
																	</div>
																					</div>
					</div>
					<div class="clear"></div>
																															</div>
									<div class="sno-footer-wrap sno-footer-wrap-tablet-footer">
																																						<div class="sno-designer-area-row snoads-unplaced">
								<div class="sno-designer-area-container sno-hac-snoads-footer" style="width: 100%;">
									<style>
	.sno-hac-inner-desktop-footer-7 {
		background: transparent;
		text-align: center;
	}
	.sno-hac-inner-desktop-footer-7 .sno-hac-adwrap {
		border: 0px solid #ffffff;
	}
	.sno-hac-inner-desktop-footer-7 {
		padding-top: 0px;;
	}
	.sno-hac-inner-desktop-footer-7 .sno-hac-adgroup-wrap .snoadrotatewidgetwrap {
		height: 120px;
		width: 100%;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-footer-7">
	<div class="sno-hac-textwrap">
					<div class="sno-hac-adwrap">
				<div class="footeradboardwrap">
	<div class="footeradboard">
		<div class="footerad snoads_footerad" data-ad_spot_id="99" data-ad_fill="" data-sno_ads_id="69"></div>
	</div>
</div>			</div>
			</div>
</div>								</div>
							</div>
																																			</div>
									<div class="sno-footer-wrap sno-footer-wrap-mobile-footer">
																																						<div class="sno-designer-area-row snoads-unplaced">
								<div class="sno-designer-area-container sno-hac-snoads-footer" style="width: 100%;">
									<style>
	.sno-hac-inner-desktop-footer-7 {
		background: transparent;
		text-align: center;
	}
	.sno-hac-inner-desktop-footer-7 .sno-hac-adwrap {
		border: 0px solid #ffffff;
	}
	.sno-hac-inner-desktop-footer-7 {
		padding-top: 0px;;
	}
	.sno-hac-inner-desktop-footer-7 .sno-hac-adgroup-wrap .snoadrotatewidgetwrap {
		height: 120px;
		width: 100%;
	}
</style>
<div class="sno-hac-inner sno-hac-inner-desktop-footer-7">
	<div class="sno-hac-textwrap">
					<div class="sno-hac-adwrap">
				<div class="footeradboardwrap">
	<div class="footeradboard">
		<div class="footerad snoads_footerad" data-ad_spot_id="99" data-ad_fill="" data-sno_ads_id="69"></div>
	</div>
</div>			</div>
			</div>
</div>								</div>
							</div>
																																			</div>
								<div class="sno-footercredit  sno-fixed-width-footer">
					<style>.sno-footercredit, .sno-footercredit a { background: #0d0c0c !important; color: #ffffff !important; }</style>
					<div class="sno-footer-credit-inner">&copy; 2021  &bull; <a target='_blank' href='https://snoads.com/site/69'>Advertise</a> &bull;  <a href='https://snosites.com/why-sno/'>FLEX Pro WordPress Theme</a> by <a href='http://snosites.com'>SNO</a> &bull; <a href="https://www.talonmarks.com/wp-login.php">Log in</a></div>				</div>
			</div>
		</div>
				<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-55863217-38', 'auto');
			ga('require', 'displayfeatures');
			ga('send', 'pageview');
		</script> 	
	<script type="text/javascript">
//<![CDATA[
//]]>
</script><script type="text/javascript">
//<![CDATA[
//]]>
</script><!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.talonmarks.com/wp-admin/admin-ajax.php";
</script>
	<div class="sno-side-icons icon-monochromatic-inverse icon-monochromatic-hover">
					<div class="comment-side-icon sno-side-icon sno-side-icon-6">
				<div class="sno-side-icon-ring">
										<i class="fa fa-comments-o"></i>
				</div>
			</div>
							<div class="like-side-icon sno-side-icon sno-side-icon-6" data-liked="0" data-remember="1" data-post="10055859" >
				<div class="sno-color-inverter" data-eae456147d4ba5c1ea18e032c08d2755="88037f936783e6bafb715fbe79a045ba"></div>
				<div class="sno-side-icon-ring">
					<div class="sno-side-icon-bubble like-count-bubble like-count-hide">
						0					</div>
					<i class="fas fa-thumbs-up"></i>
				</div>
			</div>
							<a class="modal-share" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.talonmarks.com%2Fsports%2F2021%2F12%2F19%2Foff-the-field-worst-nfl-coach-urban-meyer%2F" title="Share on Facebook" target="_blank">
				<div class="facebook-side-icon sno-side-icon sharing-mobile-show sno-side-icon-6">
					<div class="sno-side-icon-ring">
						<i class="fa fa-facebook-f"></i>
						<span class="icon-hidden-text">Share on Facebook</span>
					</div>
				</div>
			</a>
							<a class="modal-share" href="https://twitter.com/intent/tweet?text=Off The Field: Worst NFL coach Urban Meyer&amp;url=https%3A%2F%2Fwww.talonmarks.com%2F%3Fp%3D10055859" title="Tweet This Story" target="_blank">
				<div class="twitter-side-icon sno-side-icon sharing-mobile-show sno-side-icon-6">
					<div class="sno-side-icon-ring">
						<i class="fa fa-twitter"></i>
						<span class="icon-hidden-text">Share on Twitter</span>
					</div>
				</div>
			</a>
											<a href="#" onclick="return false;" class="modal-share share-email sharing-mobile-show" title="Email this Story">
				<div class="email-side-icon sno-side-icon sno-side-icon-6">
					<div class="sno-side-icon-ring">
						<i class="fa fa-envelope"></i>
						<span class="icon-hidden-text">Share via Email</span>
					</div>
				</div>
			</a>
													<a rel="nofollow" href="//www.talonmarks.com/sports/2021/12/19/off-the-field-worst-nfl-coach-urban-meyer/?print=true" title="Print this Story">
				<div class="print-side-icon sno-side-icon sharing-mobile-show sno-side-icon-6">
					<div class="sno-side-icon-ring">
						<i class="fa fa-print"></i>
						<span class="icon-hidden-text">Print</span>
					</div>
				</div>
			</a>
			</div>
	<div id="sno_hoversearch"><div class="sno-search-close"style="float:right;"><i class="fas fa-times"></i></div><div class="hover-search-area"><form method="get" id="searchform-alt" action="https://www.talonmarks.com/">
											<label for="s-alt" class="assistive-text">Search</label>
											<input type="text" class="field" name="s" id="s-alt" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
											<input type="submit" class="submit" name="submit" id="searchsubmit-alt" value="Search" />
											<button type="submit" id="sno-hover-search-button" class="sno-submit-search sno-search fa fa-search"><span class="icon-hidden-text">Submit Search</span></button>
										</form></div></div><div id="sno_hoverbar"><div class="hoverheader"><div id="hover-menu"><div class="sno-menu menu-icon"><i class="fas fa-bars"></i><span class="icon-hidden-text">Menu</span></div><div class="sno-menu close-icon" style="display:none;"><i class="fas fa-times"></i><span class="icon-hidden-text">Close Menu</span></div></div><div id="search-top"><div class="sno-search-button"><i class="fa fa-search"></i><span class="icon-hidden-text">Activate Search</span></div></div><div class="socialmedia"></div><div id="back-top"><a id="snotop" href="#top" title="Return to Top"><div class="sno-arrow-up"><i class="fa fa-arrow-up"></i><span class="icon-hidden-text">Scroll to Top</span></div></a></div><div class="lf_headerleft"><a href="https://www.talonmarks.com"><div class="sno-home menu-icon dashicons dashicons-admin-home"><span class="icon-hidden-text">Home</span></div></a></div><div class="hover_title"><div class="hover_titletext">Off The Field: Worst NFL coach Urban Meyer</div><span id="progress-bar"><span id="progress-bar-color"></span></span></div></div><div class="clear"></div></div><div id="hoverbar_menu"><ul class="slidemenu mobile-menu"><li class="mobile-search"><form method="get" class="searchform-alt-left" action="https://www.talonmarks.com/">
									<label for="s-alt-left-hoverbar" class="assistive-text">Search</label>
									<input type="text" class="field" name="s" id="s-alt-left-hoverbar" placeholder="Search" onfocus="this.placeholder = ''" onblur="this.placeholder = 'Search'"/>
									<input type="submit" class="submit" name="submit" style="display:none;" value="Search" />
								</form></li><div class="clear"></div><div class="menu"><ul>
<li class="page_item page-item-25 page_item_has_children"><a href="https://www.talonmarks.com/about/">About TM</a>
<ul class='children'>
	<li class="page_item page-item-1003236"><a href="https://www.talonmarks.com/about/media-kit-advertising/">Media Kit &#8211; Advertising</a></li>
</ul>
</li>
<li class="page_item page-item-10028023"><a href="https://www.talonmarks.com/ascc-presidential-candidate-survey/">ASCC Presidential Candidate survey</a></li>
<li class="page_item page-item-10031636"><a href="https://www.talonmarks.com/athletes-and-academics/">Athletes and Academics</a></li>
<li class="page_item page-item-192"><a href="https://www.talonmarks.com/calendar/">Calendar</a></li>
<li class="page_item page-item-10035866"><a href="https://www.talonmarks.com/tm60/">Celebrate 60 years of Talon Marks</a></li>
<li class="page_item page-item-10037443"><a href="https://www.talonmarks.com/cerritos-athletes-from-around-the-world/">Cerritos athletes from around the world</a></li>
<li class="page_item page-item-10031628"><a href="https://www.talonmarks.com/community-united/">Community United</a></li>
<li class="page_item page-item-10031626"><a href="https://www.talonmarks.com/dreamers/">Dreamers</a></li>
<li class="page_item page-item-10031623"><a href="https://www.talonmarks.com/finding-a-balance/">Finding A Balance</a></li>
<li class="page_item page-item-10048217"><a href="https://www.talonmarks.com/got-a-news-tip/">Got a News Tip?</a></li>
<li class="page_item page-item-10037445"><a href="https://www.talonmarks.com/helping-hands/">Helping hands</a></li>
<li class="page_item page-item-10037438"><a href="https://www.talonmarks.com/10037438-2/">Immigration: Student Struggles</a></li>
<li class="page_item page-item-10049566"><a href="https://www.talonmarks.com/interested-in-freelancing-for-talon-marks/">Interested in Freelancing for Talon Marks</a></li>
<li class="page_item page-item-10029126"><a href="https://www.talonmarks.com/mortal-injuries-blog/">Mortal Injuries Blog</a></li>
<li class="page_item page-item-10029134"><a href="https://www.talonmarks.com/pennies-4-diplomas-blog/">Pennies 4 Diplomas Blog</a></li>
<li class="page_item page-item-182"><a href="https://www.talonmarks.com/pollsarchive/">pollsarchive</a></li>
<li class="page_item page-item-10017193"><a href="https://www.talonmarks.com/print/">Print</a></li>
<li class="page_item page-item-10020411"><a href="https://www.talonmarks.com/grad/">Reserve your Graduation Advertisements Now</a></li>
<li class="page_item page-item-10029117"><a href="https://www.talonmarks.com/safety-matters-blog/">Safety Matters Blog</a></li>
<li class="page_item page-item-10029136"><a href="https://www.talonmarks.com/social-savvy-site-blog/">Social Savvy Site Blog</a></li>
<li class="page_item page-item-347"><a href="https://www.talonmarks.com/sports-center/">Sports Center</a></li>
<li class="page_item page-item-24"><a href="https://www.talonmarks.com/staff/">Staff</a></li>
<li class="page_item page-item-10037451"><a href="https://www.talonmarks.com/student-financial-aid-matters/">Student financial aid matters</a></li>
<li class="page_item page-item-10028029"><a href="https://www.talonmarks.com/student-trustee-candidate-survey/">Student Trustee Candidate survey</a></li>
<li class="page_item page-item-346"><a href="https://www.talonmarks.com/submit-a-letter/">Submit a Letter</a></li>
<li class="page_item page-item-10049998"><a href="https://www.talonmarks.com/subscribe/">Subscribe</a></li>
<li class="page_item page-item-351 page_item_has_children"><a href="https://www.talonmarks.com/videos/">Videos</a>
<ul class='children'>
	<li class="page_item page-item-349 page_item_has_children"><a href="https://www.talonmarks.com/videos/multimedia/">Multimedia</a>
	<ul class='children'>
		<li class="page_item page-item-10015605"><a href="https://www.talonmarks.com/videos/multimedia/photos/">Photos</a></li>
		<li class="page_item page-item-353"><a href="https://www.talonmarks.com/videos/multimedia/slideshows/">Slideshows</a></li>
	</ul>
</li>
</ul>
</li>
<li class="page_item page-item-392"><a href="https://www.talonmarks.com/about-2/">About</a></li>
<li class="page_item page-item-390 page_item_has_children"><a href="https://www.talonmarks.com/archives/">Archives</a>
<ul class='children'>
	<li class="page_item page-item-10042204"><a href="https://www.talonmarks.com/archives/talon-marks-1956-1957/">Talon Marks 1956-1957</a></li>
	<li class="page_item page-item-10042146"><a href="https://www.talonmarks.com/archives/talon-marks-1958-1959/">Talon Marks 1958-1959</a></li>
	<li class="page_item page-item-10042145"><a href="https://www.talonmarks.com/archives/talon-marks-1959-1960/">Talon Marks 1959-1960</a></li>
	<li class="page_item page-item-10042066"><a href="https://www.talonmarks.com/archives/talon-marks-1960-1961/">Talon Marks 1960-1961</a></li>
	<li class="page_item page-item-10042063"><a href="https://www.talonmarks.com/archives/talon-marks-1961-1962/">Talon Marks 1961-1962</a></li>
	<li class="page_item page-item-10042062"><a href="https://www.talonmarks.com/archives/talon-marks-1962-1963/">Talon Marks 1962-1963</a></li>
	<li class="page_item page-item-10041968"><a href="https://www.talonmarks.com/archives/talon-marks-1963-1964/">Talon Marks 1963-1964</a></li>
	<li class="page_item page-item-10041966"><a href="https://www.talonmarks.com/archives/talon-marks-1964-1965/">Talon Marks 1964-1965</a></li>
	<li class="page_item page-item-10041964"><a href="https://www.talonmarks.com/archives/talon-marks-1965-1966/">Talon Marks 1965-1966</a></li>
	<li class="page_item page-item-10041872"><a href="https://www.talonmarks.com/archives/talon-marks-1966-1967/">Talon Marks 1966-1967</a></li>
	<li class="page_item page-item-10041871"><a href="https://www.talonmarks.com/archives/talon-marks-1967-1968/">Talon Marks 1967-1968</a></li>
	<li class="page_item page-item-10041870"><a href="https://www.talonmarks.com/archives/talon-marks-1968-1969/">Talon Marks 1968-1969</a></li>
	<li class="page_item page-item-10041788"><a href="https://www.talonmarks.com/archives/talon-marks-1969-1970/">Talon Marks 1969-1970</a></li>
	<li class="page_item page-item-10041785"><a href="https://www.talonmarks.com/archives/talon-marks-1970-1971/">Talon Marks 1970-1971</a></li>
	<li class="page_item page-item-10041691"><a href="https://www.talonmarks.com/archives/talon-marks-1971-1972/">Talon Marks 1971-1972</a></li>
	<li class="page_item page-item-10041690"><a href="https://www.talonmarks.com/archives/talon-marks-1972-1973/">Talon Marks 1972-1973</a></li>
	<li class="page_item page-item-10041689"><a href="https://www.talonmarks.com/archives/talon-marks-1973-1974/">Talon Marks 1973-1974</a></li>
	<li class="page_item page-item-10041632"><a href="https://www.talonmarks.com/archives/talon-marks-1974-1975/">Talon Marks 1974-1975</a></li>
	<li class="page_item page-item-10041631"><a href="https://www.talonmarks.com/archives/talon-marks-1975-1976/">Talon Marks 1975-1976</a></li>
	<li class="page_item page-item-10041601"><a href="https://www.talonmarks.com/archives/talon-marks-1976-1977/">Talon Marks 1976-1977</a></li>
	<li class="page_item page-item-10041567"><a href="https://www.talonmarks.com/archives/talon-marks-1977-1978/">Talon Marks 1977-1978</a></li>
	<li class="page_item page-item-10041552"><a href="https://www.talonmarks.com/archives/talon-marks-1978-1979/">Talon Marks 1978-1979</a></li>
	<li class="page_item page-item-10041529"><a href="https://www.talonmarks.com/archives/talon-marks-1979-1980/">Talon Marks 1979-1980</a></li>
	<li class="page_item page-item-10041508"><a href="https://www.talonmarks.com/archives/talon-marks-1980-1981/">Talon Marks 1980-1981</a></li>
	<li class="page_item page-item-10041481"><a href="https://www.talonmarks.com/archives/talon-marks-1981-1982/">Talon Marks 1981-1982</a></li>
	<li class="page_item page-item-10041480"><a href="https://www.talonmarks.com/archives/talon-marks-1982-1983/">Talon Marks 1982-1983</a></li>
	<li class="page_item page-item-10041430"><a href="https://www.talonmarks.com/archives/talon-marks-1983-1984/">Talon Marks 1983-1984</a></li>
	<li class="page_item page-item-10041390"><a href="https://www.talonmarks.com/archives/talon-marks-1984-1985/">Talon Marks 1984-1985</a></li>
	<li class="page_item page-item-10041358"><a href="https://www.talonmarks.com/archives/talon-marks-1985-1986/">Talon Marks 1985-1986</a></li>
	<li class="page_item page-item-10041320"><a href="https://www.talonmarks.com/archives/talon-marks-1986-1987/">Talon Marks 1986-1987</a></li>
	<li class="page_item page-item-10041282"><a href="https://www.talonmarks.com/archives/talon-marks-1987-1988/">Talon Marks 1987-1988</a></li>
	<li class="page_item page-item-10041242"><a href="https://www.talonmarks.com/archives/talon-marks-1988-1989/">Talon Marks 1988-1989</a></li>
	<li class="page_item page-item-10041204"><a href="https://www.talonmarks.com/archives/talon-marks-1989-1990/">Talon Marks 1989-1990</a></li>
	<li class="page_item page-item-10041168"><a href="https://www.talonmarks.com/archives/talon-marks-1990-1991/">Talon Marks 1990-1991</a></li>
	<li class="page_item page-item-10041135"><a href="https://www.talonmarks.com/archives/talon-marks-1991-1992/">Talon Marks 1991-1992</a></li>
	<li class="page_item page-item-10041107"><a href="https://www.talonmarks.com/archives/talon-marks-1992-1993/">Talon Marks 1992-1993</a></li>
	<li class="page_item page-item-10041080"><a href="https://www.talonmarks.com/archives/talon-marks-1993-1994/">Talon Marks 1993-1994</a></li>
	<li class="page_item page-item-10041054"><a href="https://www.talonmarks.com/archives/talon-marks-1994-1995/">Talon Marks 1994-1995</a></li>
	<li class="page_item page-item-10041030"><a href="https://www.talonmarks.com/archives/talon-marks-1995-1996/">Talon Marks 1995-1996</a></li>
	<li class="page_item page-item-10041003"><a href="https://www.talonmarks.com/archives/talon-marks-1996-1997/">Talon Marks 1996-1997</a></li>
	<li class="page_item page-item-10040978"><a href="https://www.talonmarks.com/archives/talon-marks-1997-1998/">Talon Marks 1997-1998</a></li>
	<li class="page_item page-item-10040954"><a href="https://www.talonmarks.com/archives/talon-marks-1998-1999/">Talon Marks 1998-1999</a></li>
	<li class="page_item page-item-10039474"><a href="https://www.talonmarks.com/archives/talon-marks-1999-2000/">Talon Marks 1999-2000</a></li>
	<li class="page_item page-item-10039443"><a href="https://www.talonmarks.com/archives/talon-marks-2000-2001/">Talon Marks 2000-2001</a></li>
	<li class="page_item page-item-10039395"><a href="https://www.talonmarks.com/archives/talon-marks-2001-2002/">Talon Marks 2001-2002</a></li>
	<li class="page_item page-item-10039363"><a href="https://www.talonmarks.com/archives/talon-marks-2002-2003/">Talon Marks 2002-2003</a></li>
	<li class="page_item page-item-10039314"><a href="https://www.talonmarks.com/archives/talon-marks-2003-2004/">Talon Marks 2003-2004</a></li>
	<li class="page_item page-item-10039262"><a href="https://www.talonmarks.com/archives/talon-marks-2004-2005/">Talon Marks 2004-2005</a></li>
	<li class="page_item page-item-10039258"><a href="https://www.talonmarks.com/archives/talon-marks-2005-2006/">Talon Marks 2005-2006</a></li>
	<li class="page_item page-item-10039110"><a href="https://www.talonmarks.com/archives/talon-marks-2006-2007/">Talon Marks 2006-2007</a></li>
	<li class="page_item page-item-10039074"><a href="https://www.talonmarks.com/archives/talon-marks-2007-2008/">Talon Marks 2007-2008</a></li>
	<li class="page_item page-item-10039043"><a href="https://www.talonmarks.com/archives/talon-marks-2008-2009/">Talon Marks 2008-2009</a></li>
	<li class="page_item page-item-10039014"><a href="https://www.talonmarks.com/archives/talon-marks-2009-2010/">Talon Marks 2009-2010</a></li>
	<li class="page_item page-item-10038311"><a href="https://www.talonmarks.com/archives/talon-marks-2010-2011/">Talon Marks 2010-2011</a></li>
	<li class="page_item page-item-10038278"><a href="https://www.talonmarks.com/archives/talon-marks-2011-2012/">Talon Marks 2011-2012</a></li>
	<li class="page_item page-item-10038242"><a href="https://www.talonmarks.com/archives/talon-marks-2012-2013/">Talon Marks 2012-2013</a></li>
	<li class="page_item page-item-10038183"><a href="https://www.talonmarks.com/archives/talon-marks-2013-2014/">Talon Marks 2013-2014</a></li>
	<li class="page_item page-item-10038153"><a href="https://www.talonmarks.com/archives/talon-marks-2014-2015/">Talon Marks 2014-2015</a></li>
	<li class="page_item page-item-10038112"><a href="https://www.talonmarks.com/archives/talon-marks-2015-2016/">Talon Marks 2015-2016</a></li>
	<li class="page_item page-item-10038060"><a href="https://www.talonmarks.com/archives/talon-marks-2016-2017/">Talon Marks 2016-2017</a></li>
	<li class="page_item page-item-10038050"><a href="https://www.talonmarks.com/archives/talon-marks-2017-2018/">Talon Marks 2017-2018</a></li>
</ul>
</li>
<li class="page_item page-item-10043004"><a href="https://www.talonmarks.com/classifieds/">Classifieds</a></li>
</ul></div>
</ul></div><script type="text/javascript">
			jQuery(document).ready(function(){
				
				// disabling this feature when using new scrollToFix elements in header
				if( jQuery('.sno-header-row-stick').length ) return;
	
				function sharingIconsResize() {
					if (jQuery(window).width() < 850) {
						var socialwidth;
						var count = jQuery("#mobile-socialmedia .sharing-mobile-show").length;
						if (count != 0) {
							socialwidth = 100 / count;
							jQuery('#mobile-socialmedia .sharing-icon').width(socialwidth + '%');
						}
					} else {
						jQuery('#sno_hoverbar .sharing-icon').width('50px');
					}
				}
								
				jQuery('.sno-search-button').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '0' });
					jQuery('#s-alt').focus();
				});
				jQuery('.sno-search-close').click(function() {
					jQuery('#sno_hoversearch').fadeToggle();
					jQuery('#sno_hoversearch').css({ top: '-50px' });
				});
	
				var NavScrollTop		= jQuery(window).scrollTop();
	    		
	    		if( jQuery('.navbarwrap').length ) {
	    			var	TopNavOffset 		= jQuery('.navbarwrap').offset().top;
					var TopNavDistance		= (TopNavOffset - NavScrollTop);
	   	 		}
	   	 		if( jQuery('.subnavbarwrap').length ) {
		   	 		var	BottomNavOffset 	= jQuery('.subnavbarwrap').offset().top;
		   	 		var	BottomNavDistance	= (BottomNavOffset - NavScrollTop);
	   	 		}
	   	 		
	   	 		jQuery('#hoverbar_menu .mobile-menu').height( jQuery(window).height() - 50);
	   	 		
	   	 		var HoverOffset = 0, HoverOffset2 = 0;
					   	 		var HoverHeight = jQuery('#sno_hoverbar').outerHeight();
	   	 		var HoverHeight2 = jQuery('#sno_hoverbar').outerHeight();
	   	 		
					
				var CurrentScroll = 0;
				var WindowHeight = jQuery(document).height() - jQuery('.footer').height();
				
									WindowHeight -= jQuery('#commentswrap').height();		
								
								
				jQuery(window).scroll(function(event) {
					var NextScroll = jQuery(this).scrollTop();
	
					var ScrollPercent = (NextScroll / (WindowHeight - jQuery(window).height())) * 100;
					
					jQuery('#progress-bar-color').css({ width: ScrollPercent + '%'});
					jQuery('#hoverbar_menu').css({ top: jQuery('#sno_hoverbar').height() });
					
					var headerLocation = jQuery("#wrap").offset().top;
					if (NextScroll > CurrentScroll && jQuery(document).scrollTop() > headerLocation) {
						if (jQuery('#sno_hoverbar').is(":hidden")) {
							jQuery('#sno_hoverbar').show();
							jQuery('#sno_hoverbar').stop().animate({ top: '0' }, { duration: 300, queue: false });
								
														
															var lpb = jQuery('.lf_headerleft').width();
								lpb += jQuery('#sno_hoverbar .sno-menu').width(); 								var rpb = 50 + jQuery('.socialmedia').width();
																	rpb += jQuery('#sno_hoverbar .sno-search-button').width();
																jQuery('#progress-bar').css({ left: lpb + 'px', right: rpb + 'px'})
								        			}
	
	
	        			
					} else if (NextScroll < CurrentScroll && jQuery(document).scrollTop() < ( headerLocation + 300 ) && jQuery('#sno_hoverbar').is(":visible")) {
						
							jQuery('#hoverbar_menu').hide();
							jQuery('.close-icon').hide();
							jQuery('.menu-icon').show();
							jQuery('#hoverbar_menu').hide();
							jQuery('#sno_hoverbar').stop().animate({
								top: '-50px'
								},300, function(){
									jQuery('#sno_hoverbar').hide();
								});
							if ( jQuery('.navbarwrap').length ) { jQuery('.navbarwrap').stop().animate({ top: HoverOffset + 'px'},300); }
							if ( jQuery('.subnavbarwrap').length ) { jQuery('.subnavbarwrap').stop().animate({ top: HoverOffset2 + 'px'},300); }
	
					}
				CurrentScroll = NextScroll;
				});
	
	
			});
	
		</script><div class='remodal-story-image' data-remodal-id='modal-photo' data-remodal-options='hashTracking: false, closeOnConfirm: false'><button data-remodal-action="close" class="remodal-close sno-overlay-close"><span class="icon-hidden-text">Close</span></button><div class="remodal-inner-container"></div></div><div class="remodal-share-story" data-remodal-id="modal-share" data-remodal-options="hashTracking: false, closeOnConfirm: false"><button data-remodal-action="close" class="remodal-close"><span class="icon-hidden-text">Close Modal Window</span></button><div class="remodal-share-inner-container"></div></div>		<div id="sno-comments-side">
			<div class="sno-comments-wrap">
				<div id="sno-comments-header">
					<div class='fas fa-times comment-close-icon'></div>
					<div class="sno-comments-title"><h3>Comments (0)</h3></div>
				</div>
									<div class="clear"></div>
									<input class="comments-share-thoughts" type="text" placeholder="Share your thoughts..." name="comments-thoughts"/>
								<div class="comments-toggle">
					<span class="comments-all comments-toggle-active">All</span>
									<span class="comments-staff-picks">Talon Marks Picks</span>
													<span class="comments-reader-picks">TM Reader Picks</span>
									<span class="comments-sort" data-sort="newest">Sort: <span class="active-sort">Newest</span></span>
				</div>
									<div id="comments" class="comments-area default-max-width show-avatars">
		<div id="respond" class="comment-respond">
		<p id="reply-title" class="comment-reply-title"> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/sports/2021/12/19/off-the-field-worst-nfl-coach-urban-meyer/#respond" style="display:none;">Cancel reply</a></small></p><form action="https://www.talonmarks.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><div class="sno_spam_control"><label for="spam_stopper">Spam Control Field.</label><input type="text" name="sno_is_legit_comment" id="spam_stopper" value="SNO_Spam_Stopper"/><label for="sno-verification">Verification Field.</label><input type="text" name="sno-verification" class="sno-verification" id="sno-verification" value="76662e5f9815c56cf5a8bf9509446f0088037f936783e6bafb715fbe79a045ba"/></div><input id="wp-remember" type="hidden" name="wp-remember" value="1" /><div class="sno-comment-id" data-520bb9b36df7a859b7157e09d42bce44="88037f936783e6bafb715fbe79a045ba"></div><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='10055859' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8a03ae8ad1" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js" name="ak_js" value="9"/><script>document.getElementById( "ak_js" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
	</div>							</div>
		</div>
		<script type='text/javascript' id='thickbox-js-extra'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/www.talonmarks.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105' id='thickbox-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-includes/js/comment-reply.min.js?ver=5.8.2' id='comment-reply-js'></script>
<script type='text/javascript' id='ytwd_frontend_main-js-js-extra'>
/* <![CDATA[ */
var ytwdGlobal = {"ajaxURL":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php","YTWD_URL":"https:\/\/www.talonmarks.com\/wp-content\/plugins\/wd-youtube","txt_show_more":"Show More","txt_show_less":"Show Less","txt_loading":"Loading"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/wd-youtube/js/frontend_main.js?ver=1.0.20' id='ytwd_frontend_main-js-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/Chart.js/3.5.0/chart.min.js?ver=1.0.0' id='chartsjs-main-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/chroma-js/2.1.0/chroma.min.js?ver=1.0.0' id='chroma-lib-js'></script>
<script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/d3/3.5.3/d3.min.js?ver=1.0.0' id='d3-lib-js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/topojson/1.6.9/topojson.min.js?ver=1.0.0' id='topo-json-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-infographics//assets/datamaps/datamaps.all.min.js?ver=1.0.0' id='datamap-main-js'></script>
<script type='text/javascript' id='sno-infographics-widget-script-js-extra'>
/* <![CDATA[ */
var sno_infographics_ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-infographics/assets/script/sno-infographics-widget.js?ver=0.2.5' id='sno-infographics-widget-script-js'></script>
<script type='text/javascript' src='https://code.jquery.com/ui/1.12.1/jquery-ui.js?ver=5.8.2' id='ui-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-plugin-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-pdf-flipbook/assets/script/sno-pdf-flipbook-script.js?ver=1.0.5' id='sno-pdf-flipbook-plugin-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-turnjs-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-pdf-flipbook/assets/script/turn.js?ver=1.0.0' id='sno-pdf-flipbook-turnjs-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-mousewheel-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-pdf-flipbook/assets/script/jquery.mousewheel.min.js?ver=1.0.0' id='sno-pdf-flipbook-mousewheel-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-hash-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-pdf-flipbook/assets/script/hash.js?ver=1.0.0' id='sno-pdf-flipbook-hash-script-js'></script>
<script type='text/javascript' id='sno-pdf-flipbook-modernizr-script-js-extra'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-pdf-flipbook/assets/script/modernizr.2.5.3.min.js?ver=1.0.0' id='sno-pdf-flipbook-modernizr-script-js'></script>
<script type='text/javascript' id='custom-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-polls/assets/script/sno-polls-widget.js?ver=0.0.5' id='custom-widget-script-js'></script>
<script type='text/javascript' id='custom-test-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-polls/assets/script/sno-polls-test-widget.js?ver=0.0.3' id='custom-test-widget-script-js'></script>
<script type='text/javascript' id='custom-quiz-widget-script-js-extra'>
/* <![CDATA[ */
var sno_polls_ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-polls/assets/script/sno-polls-quiz-widget.js?ver=0.0.3' id='custom-quiz-widget-script-js'></script>
<script type='text/javascript' id='custom-popup-script-js-extra'>
/* <![CDATA[ */
var sno_student_news_source_ajax_object = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/sno-student-news-source/assets/script/sno-student-news-mobile-popup.js?ver=0.0.2' id='custom-popup-script-js'></script>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/www.talonmarks.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
<script type='text/javascript' id='mc.grid-js-extra'>
/* <![CDATA[ */
var mcgrid = {"grid":"true"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/my-calendar/js/mc-grid.js?ver=3.2.19' id='mc.grid-js'></script>
<script type='text/javascript' id='mc.list-js-extra'>
/* <![CDATA[ */
var mclist = {"list":"true"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/my-calendar/js/mc-list.js?ver=3.2.19' id='mc.list-js'></script>
<script type='text/javascript' id='mc.mini-js-extra'>
/* <![CDATA[ */
var mcmini = {"mini":"true"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/my-calendar/js/mc-mini.js?ver=3.2.19' id='mc.mini-js'></script>
<script type='text/javascript' id='mc.mcjs-js-extra'>
/* <![CDATA[ */
var my_calendar = {"newWindow":"Opens in new tab"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.talonmarks.com/wp-content/plugins/my-calendar/js/mcjs.js?ver=3.2.19' id='mc.mcjs-js'></script>
<div id='sno-pdf-flipbook-full'></div>	</body>
</html>